Adding FTPS port

I try to expose service through FTPS port.
I have self signed certificate configured in “Certificates” window.
When I try to enable FTPS port receive error:

Failed to start FTPSListener@5989: PublicKey algorithm not implemented: sha256WithRSAEncryption

I tried to use diferent algorithms but always have similar error…

Can anyone help? I think that there is problem with my certificate, but how to generate it corectly?.

Best Regards

I have WM 7.1.2 and I use XCA (openssh) to generate certificate.
How you configure it? Because I see that you use FTPS and it works for you…

R u speciying Listener Specific Credentials ?? If yes then what is the need of it as FTPS can be enabled without ‘Listener Specific Credentials’ configuration.

It works for me now.
Problem was that I conected cert file instead of private key.
Now I generated private key (RSA 1024bit), and self signed certificate.
Exported both in DER format.
next I configured “Listener Specific Credentials”:
Server’s Certificate: path to cert file in DER format
Authority’s Certificate: path to same file as above
Private Key: path to key file in DER format

And everything works OK.
Thanks for help :wink:

Best Regards