AdapterNotification Problem in JDBCAdapter

Hi all,

Here i am facing one problem.I set up Alias for JDBCAdapter.I set up
Pooling connection period.Now I am trying to create AdapterNotification
on that database using JDBCAdapterNotification template.

           I am getting below error. 

com.wm.app.b2b.server.ServiceException: [ART.114.235] Adapter Runtime (Metadata): Error in getNotificationAdapterMetadata. Missing parameter: adapterTypeName.

com.wm.ui.UiException: com.wm.app.b2b.server.ServiceException: [ART.114.235] Adapter Runtime (Metadata): Error in getNotificationAdapterMetadata. Missing parameter: adapterTypeName.

when i looked into getNotificationAdapterMetadata service in WMART
package,this service needs adapterTypeName parameter as input.
where did it gets this information?

thanks,
SriniK

wow - I thought I was alone. I am getting that exact same error. I have created update and insert notifications on that adapter in the past, and they have worked fine. Recently, I installed SP2 and SP1_Fix_43 though - I wonder if that is causing some problems. Because now, I am getting this error on ALL my adapters, even if I create a new one from scratch. It will let me create SELECT and INSERT adapter services, but it gives me the same ART.114.235 error you’re getting when I try to create adapter notifications.

Jeremy

Hi Jeremy,

I figure out in SP2_fix it is asking AdapterTypeName parameter.In  

my localHost,I didn’t apply any service packs.So it is allowing me
to create adapterNotification.My Dev,test,Staging environments we applied SP1,SP2_fixes (These environments i am getting above problem).
we are not applied SP2 on Production environment.So my previous notifications on Prod working fine.So I came in conclusion In SP2_fix
we need additional parameters.When i open wmART package in my local
box i observed there is no AdapterTypename parameter(input).I am not applied any service packs (reason i am not using Jdk1.4).we open
ticket regarding this issue.

Thanks,
sriniK

There are some upgrade steps when installing SP1 (or when going directly to SP2) which are described in the readme (see IS_6-0-1_SP2_README.txt for SP2) that have to do with JDBC datasource definitions. I’m not sure of the details of the manifestation of not running the update scripts, but that would be good to verify that isn’t the problem.

Jeremy/Hartman,

   Today I received servicePak for developer/IDE(wb601sp1developer) 

from my Administrator.This service pak for developerConsole/IDE
in order to interact with servers that have service pak 2 installed.
According to his mail from webMethods will support to create JDBC
Notifications.Contact webMethods support.I am going to apply it now.

Thanks,
sriniK

Hi Jeremy,

    I applied wb601sp1developer on my m/c now notification is  

working for me.so pl contact WebMethods support to get developer

service pack.

Thanks,
SriniK

yes - I just found the same thing. Integration Server SP2 requires that you install Developer SP1. Thanks.

Hi Jeremy,

 I have one question.Did you ever used storedProcedure service 

in JDBC Adapter?If yes,did you pass parameter date into your stored

-Procedure.I am facing problem when I pass date parameter into

JDBC storedProcedure service.I passed like yyyy-MM-dd HH:mm:ss/ss.s

format.Same thing working fine for me in wmDb package.If i pass

date parameter like dd-MMM-yyyy format for wmDB package.

Thanks,
Srini