Adapter RunTime Error

Hi Could anyone solve my issue,

I am working in wM 8.2 version , While i am trying to insert the “CHK-77188” values from the IS service to the Z3ALPH filed of “F47113” record i am getting following error

[ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service pxEDI820_X12_V4010.inbound.AdapterServices:insertF47113Record.
[ADA.1.316] Cannot execute the SQL statement “INSERT INTO F47113(Z3EDTY, Z3EDSQ, Z3EKCO, Z3EDOC, Z3EDCT, Z3EDLN, Z3EDSP, Z3EDBT, Z3DEPN, Z3LNID, Z3DOCM, Z3DCTM, Z3DMTJ, Z3DKC, Z3AN8, Z3ALPH, Z3TNST, Z3CBNK, Z3THCD, Z3PYCD, Z3PYIN, Z3AM, Z3CRCD, Z3CRR, Z3CRRM, Z3TTOT, Z3ICU, Z3ICUT, Z3DICJ, Z3URCD, Z3URDT, Z3URAT, Z3URAB, Z3URRF, Z3TORG, Z3USER, Z3PID, Z3JOBN, Z3UPMJ, Z3TDAY) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)”. "
(42S02/208) [Microsoft][SQLServer 2000 Driver for JDBC][SQLServer]Invalid object name ‘F47113’."
[Microsoft][SQLServer 2000 Driver for JDBC][SQLServer]Invalid object name ‘F47113’.

Please help me out from this issue.
Would appreciate any responds.

Hi Laxman,

This error is generated when a table is pre-fixed with the schema other than dbo. Please check.


Hi Mohit,

Thanks for responding to my mail. As i am not familiar with Adapters ,i am unable to find the solution as you suggested me . Could you elaborate how to check the schema ?

You should check on the JDBC Adapter Connection that this insert service is associated and make sure the configuration is right.

Are you running this insert first time or did the service worked before?



This is not first time to insert the values in F47113 Record. It was worked fine. I will check the JDBC Configuration.
Thanks a lot for responding to my mail.

OK.Pls check with your DBA team also and get their inputs.

Sure RMG ,Thanks for you helping

you bet:)