Access denied to invoke on remote server

Hi everyone,

We had a glitch with one of our services last night when it tried to run a remote invoke, which resulted in the following error:

‘Access denied to invoke on remote server EDG2PRDProtocol’

EDG2PRDProtocol is the remote server alias for a second instance of IS running on another server. The alias uses the ‘Administrator’ user, and the Internal ACL (which is in Developer and Admin groups) so I don’t think permissions should be an issue.

Hitting the test button under ‘Settings > Remote Servers’ works fine, so I know the connection to the remote server is ok.

The service worked fine the day before, but now fails with the above error every time! We’ve done no changes to the system.

But oddly, if you run the same code via developer it works fine, even stepping through runs fine, so I’m having some issues with debugging. But when run normally it still fails!

Anyone any ideas?

We are using IS 6.5 running on AIX boxes.


Do you have developer on your production server or did you run this test from a development server? Had anything changed in production when this occurred? New firewall rules?

I ran Developer on my local Win XP PC but connecting directly to the Production IS server on AIX. Normally we only use Developer on our Development environment, also on AIX, but we still have Developer access to Production to help with support issues. (Only the developers have Developer installed, the support bod’s don’t have Developer).

Nothing had been changed on the server, all firewall rules are still in place etc.

I did a restart of IS (from the web interface) and the problem went away, everything is working fine again now. So as far as I can tell all the code, permissions, firewalls etc are all ok, as it now works again.

But for some reason it stopped working last night until the restart today.

I did find out, after sending the above post, that there had been an out of memory error late yesterday afternoon, after someone tried to send a rather large file through the system by mistake (144MB!). Everything seemed to continue working after that, so nothing further was done.

Could that out of memory error have caused the above problems? Perhaps some IS component was hung in the background, or the memory used hadn’t been freed again or was corrupted somehow?


Also as some additional info, running built in services, such as ’’ as a remote invoke to the same environment work fine.

It just doesn’t seem to like running code in our packages as remote invokes anymore!

But the same packages on our test environment work fine!


We did a reboot of the remote server today and everything is working again now!

So no one any further thoughts on why this has happened?

It’s just that it happened again last night, no other errors in the log, it just decided to stop allowing certain remote invokes to run again, but not all!

wM 6.5 doesn’t seem to be too resilient so far!