403 Access Denied...

I’m getting a weird 403 Access Denied to my SOAP client (a ColdFusion MX script). The webmethods service has its Execute ACL set to “Anonymous” and the service begins execution, because it successfully executes a savePipelineToFile which I placed at the front to test.

But some way thru execution, it receives this:

Could not perform web service invocation “” because AxisFault faultCode: {http://xml.apache.org/axis/}HTTP faultSubcode: faultString: (403)Access denied faultActor: faultNode: faultDetail: {}string: return code: 403 The user that posted this document (Default) could not be associated with a partner to check their identity.

If I change the Execute ACL to, ie, “Default”…the SOAP client can’t even access the service, so the “Anonymous” setting is correct…it just has a 403 error midway thru execution…?

Any ideas what causes this kind of behavior?

Thanks.

Luke,

Can you capture the soap messages using a tool like PocketSoap TCPTrace?

Sounds like ColdFusion MX axis client may be having trouble processing your response possibly because the ColdFusion user is different than the service consumer.

Mark

I don’t quite understand how to configure tcpTrace. Should I run it on the ColdFusion MX server, or the webMethods server? If I run it on the ColdFusion server, do I configure the destination server as my webmethods machine, and port 80?

Can I just run a generic packet-sniffer like Ethereal?

I’ll try to watch the traffic, but, I invoked another webmethods service via WSDL/SOAP from the same CF server and the other soap rpc runs fine. So maybe it isn’t something at the server/communications layer…I think there’s something specifically in the service or package that is causing the problem.

You can run it on either server. It will listen on the port that you specify and then forward the request to the server and port that you choose.

If you run it on the Coldfusion MX server, you would listen on some port (5555 or other) and specify your IS hostname and port.

See the PocketSoap/TCPTrace page for detailed instructions.

See the attached screenshot for an example.

Mark
pocket_soap_IS_config.JPG