XSLT mapping issue

Hi all,
I have created an XSLT mapping from the XSD provided.
Now, am trying to run the XSLT with the input.

Am getting an error as :
com.wm.app.b2b.server.ServiceException: [XSL.0002.9001] JAXP: Error instantiating transformer - com.wm.pkg.xslt.util.LocalizedTransformerException: [XSL.0002.9002] JAXP: Error during transformation - com.wm.pkg.xslt.util.LocalizedTransformerException: [XSL.0002.9002] JAXP: Error during transformation - Could not find function: adjust-dateTime-to-timezone; Line#: 7; Column#: 80

For reference, the statement in line #7 is:
<xsl:value-of select=“adjust-dateTime-to-timezone(current-dateTime(),null)”/>

Iam new to XSLT and am not aware of how the transformer works in XSLT.

Can anybody suggest me on this?
Thanks in advance.

Regards,
Krithiga M

hi Krithiga,
i guess your XSLT engine supports version 1.0 and not XSLT 2.0. These functions are in XSLT 2.0.
You might need to look into your IS’ xslt engine.

-regards,
DC

Hi Deepan,
Thanks for your suggestion.
But yes, am aware of the XSLT version as 2.0 and that is the reason why we have developed it in webM 8.0.

I heard that XSLT 2.0 will work in webM 8.0

But anyways, can you tell me where we have to check for the XSLT engine settings that you had mention?

Please let me know about the exact values to be set too.

Thanks and Regards,
Krithiga M

You can check the version of XSLT supported in wM XSLT Developer guide for that version of wM. You can get the document from http://techcommunity.softwareag.com/ecosystem/documentation.

I think wM 8 supports multiple xslt engine which you can choose from WmXSLT homepage, you should be able to setup the xslt engine which supports version 2.0. Best way is go through the documents and try using different xslt factory, else download jar files for other xslt 2.0 factory and try using them. i do not have wM 8 so can not help more.

-regards
DC

Hi all,
The problem is solved now.
I have modified the XSLt transformer settings in the homepage.
I have set the following value in the wMXSLT homepage.
TransformerFactory:
net.sf.saxon.TransformerFactoryImpl

Thanks to everyone.

Regards,
Krithiga Muralidharan

Hi Can you please let me know where the settings was applied please?

it worked fine thanks :slight_smile:

Via this http://localhost:5555/WmXSLT/settings-edit.dsp