Workflow step status is completed but process status is started

I am using MwS 7.0 with task engine & IS 6.5 SP3.
I am working on bootcamp exercise for WM 7.0.
I am successful in creation of a process model and it gets invoked by publishing the document. When it comes to a workflow task, task gets queued as it should. As per the process, I accept and complete the task.
While looking at the process instance steps, it task status is completed but the process status is still ‘started’ and next step after workflow task does not get executed.
Any idea about this issue?
Error I saw in MwS logs is:

2008-05-02 11:02:49 PDT (Framework : WARN) - [PRT.0101.9130] Error sending wm.prt.dispatch:ProcessTransitionVol: >>>BasicData:ProcessInstanceID=94dc87a0186f11dda8a99b3ce5d8f16a:1,ProcessModelID=MyProcess/MyFirstProcess,ProcessModelVersion=1,SourceStepID=PRETDE_S17,TargetStepID=POSTTDE_S17,SourceServerID=Default,Pipeline=[B@177a174< [PRT.0101.9130] Error sending wm.prt.dispatch:ProcessTransitionVol: >>>BasicData:ProcessInstanceID=94dc87a0186f11dda8a99b3ce5d8f16a:1,ProcessModelID=MyProcess/MyFirstProcess,ProcessModelVersion=1,SourceStepID=PRETDE_S17,TargetStepID=POSTTDE_S17,SourceServerID=Default,Pipeline=[B@177a174< at at at wm.prt.tde.sendTransition( at wm.prt.tde.tdeCallback( at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at at at at at at at at at at at at at at at


hi ndgohel: I see the same error as you, could you please tell me how to solve this? thank you very much!

same problem for me too,can some one pls reply

Thanks in advance,

I solved this problem long time ago. this is because the task engine can’t access the process engine and can’t report the task complete message to process engine. So you should check if the connection is right or not in your mws system setting.

hope this can help you

Hi jacky_sx,

Thanks for the reply.
In mws system settings, I have given the username and password as Administrator and manage.But still I am getting the same error.

Do you see any other reasons for this?

the username and password is for process engine to connect to task engine. you should check your setting for Integration Server (Process Engine Host)

In my case, finally I found I provide wrong connection address
the address I input was http://localhost
but actually the right string is just “localhost”

If you are sure about the address, i am afraid you should check if process engine is running well.


I have faced the same issue with the process and the task

The workaround i could find for the same is as below:

  1. Go to the developer and delete the process package which has been created initially.
    2.Go to Designer and delete the input /output steps for the tasks(As u can c the input and output with same as task name)
    3.Close the Designer and open again,so that you can see the input and output has been created automatically.
    4.Now build and upload the process.
    5.Check for the Result