WmSAP package partially loaded in IS 10.7

Hi All,

I have installed the trial version for Software AG webmethods 10.7 . All the packages and installations are done properly except for WmSAP package. The package is partially loaded, I have tried reloading the package from IS but the issue still exists. Error that I am getting is:

wm.sap.Admin:registerTransactionStore - com/wm/adapter/sap/util/Log
wm.sap.Admin:registerLocalConnection - com/sap/conn/jco/JCoException
wm.sap.Admin:registerAdapter - java.lang.NullPointerException
wm.sap.Admin:registerRoutingListener - com/sap/conn/jco/JCoException

Could you please help me resolve this issue.

Regards,
Nikita

Have you placed the sap libraries to the classpath as described on page 4-5 of the intstallation guide ?

I have attache the guide here for reference.

webMethods SAP Adapter Installation Guide 6.5 Service Pack 1.pdf (318.3 KB)

regards
John Carter
Product Manager
Integration & Microservice runtime

1 Like

Hi Nikita,

this is correct so far as long as you do not add the SAP specific JCo 3 (and JCo IDoc 3) libraries to the SAP Adapter package.
As they have a native platform dependent part they are not bundled with the SAG installation but need to be downloaded from SAP Marketplace.
You will require a so called S-Account there which can be provided by the license management of your SAP system partner if you need to integrate with them.

When you do not need to integrate with SAP systems, you can either ignore this message or just disable the SAP Adapter package WmSAP at all.

Additional Info:
As the SAP libraries have a native part, reloading the package does not help even when the libs are present or replaced by newer version. This will always require a shutdown and restart of the IS to get the native part loaded properly.

Regards,
Holger

Hi John,

I assume that the Trial 10.7 has already bundled a SAP Adapter 10.1 instead of 6.5.
Even the wM 7.x, 8.x and 9.x series have a SAP Adapter 7.1 available.
SAP Adapter 6.5 and earlier were the last ones using the older JCo 2 libs.
SAP Adapter 7.1 and newer are using the newer JCo3 libs.

Regards,
Holger

Oops, sorry I attached the wrong version.

Refer to page 37 of the following document.

10-1_SAP_Adapter_Install_and_Users_Guide.pdf (5.0 MB)

Thanks @Holger_von_Thomsen

John.