WM61 Reverse Invoke set up problem

I have just set up an RI IS for the first time and tried to test it by invoking a service through the proxy port, when I do I get the following error dump:
java.lang.ClassCastException at com.wm.app.b2b.server.comm.revinvoke.CommProtocolInfoImpl.(CommProtocolInfoImpl.java:42) at com.wm.app.b2b.server.comm.DefaultSocketRequestHandler.handleMessage(DefaultSocketRequestHandler.java:127) at com.wm.util.comm.Connection.handleMessage(Connection.java:136) at com.wm.util.comm.Connection$PollRunner.run(Connection.java:465) at com.wm.util.pool.PooledThread.run(PooledThread.java:105) at java.lang.Thread.run(Thread.java:534)

Anyone seen this before?
As far as I can tell everything is configured correctly,
It’s on windows server 2003

I have encountered errors on RI setups alot of times due to incorrect security settings.
A couple of thoughts/questions:
1- What kind of authorization/authentication do you have on the RI port? and does this match with the setup on the internal server?
2- Can you see RI connections registered on the internal and RI servers?



I am getting the same error on my RI port, did you manage to sort out the problem?