WebSphere MQ Adapter Installation

I’m currently installing the wM WebSphere MQ Adapter. The MQ version is 5.x . As per the MQ Adapter installation guide, [FONT=PalatinoLinotype-Roman][SIZE=2]

For WebSphere MQ 5.x: [/size][/font][FONT=PalatinoLinotype-Italic][SIZE=2]WebSphereMQ_directory[/size][/font]\java\lib[B]com.ibm.mq.pcf.jar [/b], is the client.jar file required. However, my MQ team didn’t find this .jar file at their MQ installation.
I’ve received only the mqjbnd[FONT=Arial Narrow][SIZE=4]nn.dll from them. [/SIZE][/FONT]
What do i need to do now?

Thnx.
[FONT=PalatinoLinotype-Roman][SIZE=2][FONT=Arial Narrow][SIZE=4]-Bond.

[/SIZE][/FONT][/SIZE][/FONT]

Check with IBM Support as you should be able to download any needed jar files for MQ client applications from IBM’s web-site.

I’ve downloaded the required PCF jar file from the IBM site. I’ve put the jar files in the adapter installation dir as per installation guide & added the path in the PATH variable. But still, MQ Adapter is not appearing in the the Adapters list in Integration Server Admin page.
I tried to resolve this by restarting the server, but it doesn’t help.
Do i need to re-install the MQ Adapter?:rolleyes: Or what else, i need to do?

-007

The issue is resolved now:D .
Actually, the .dll file was not at any of the locations specified my the PATH variable. I just placed it in \WmMQAdapter\code\jars location.:slight_smile:

Thanks.
-Bond :cool:

Yes afer that you need to restart the server :slight_smile: … Thanks

Hi all,
I’m also facing the same issue. I have installed the webmethods 7.1 version but i’m unable to see the websphere mq adapter option in the admin page.
As u ppl suggested i have checked in the ibm site but no use.
Pls could you provide the direct link where i can download this file mqjbndnn.dll and path where i have place it.
pls take it as high priority.

thanks.

Hi Shyam,

While selecting Websphere MQ Adapter 6.5 during the installation of WM7.1, it wont ask to locate the jar files.

Place the com.ibm.mq.jar in \webMethods71\IntegrationServer\packages\WmMQAdapter\code\jars folder.

Restart the IS.

You can see Websphere MQ Adapter appearing in the Admin page under Adapters.

Hope this solves ur problem!!!

Regards,
Senthil G

Hi Senthil,

thanks for your response. I’ll chk and will update to you.

thanks,
shyam