webservice WSDL in wm 8.0

hello,
this is a question regarding wm 8.0
In 6.5 we do have an option like Generate WSDL inside the Tools menu.
We use to create the wsdl for a webservice and create a connector with it locally to test a webservice.

But in webmethods 8.0 there is no option to generete a WSDL directly.
I read the guide but could not succeed.

Can any body help me with this?

Regards,
Krithiga

You can get the WSDL by clicking on right most buttons on service view screen…

there are two options … view WSDL and anlyase for complaince… use the first one and get your WSDL.

Alternatively you can always get the wsdl from wsdl url which can be extracted from WSDL URL property from properties window for WS descriptor.

-nD

hi
am new to web service.
can you please tell me which screen you want me to look for the right most buttons?
Also, the scenario is i have a webservice created already. the partner will invoke the service with a request.
So, i have to provide the wsdl to the partner if am rite.
So, how can i generate it now?
Thanks in advance

Krithiga

yes your understanding is right, you can either provide the WSDL file or WSDL url’s to partner.

to get the WSDL file as suggested in last post… open your WS descriptor… look onto right top on the service canvas (where u write the flow code) there you will the options.

PS: Go through webservice developer guide from Wm documentation… it will be helpful for all queries, if u stuck somewhere post here.

cheers!
nD

I never really use it, but I think you nedd to create a “Web Service Descriptor”:

  • In Developer 8, you just need to create a “Web Service Descriptor” and then select the service you want. On its properties, copy-paste the “WSDL URL” in your internet brower and it will display the WSDL.

  • In Designer 8 (seems easier), you just need to select your service and select “Generate Provider WSD”. A Web Service Descriptor is created and after you have a WSDL tab.

I hope it’s right !
Strange the Generate WSDL option is not available.
:slight_smile:

Hi nd and aruna,
I did the same.
I created a wm descriptor with the following options.
Created wsd as “Provider”
web service source: Existing IS service
Enforce ws-1 Basic Profile 1.1 compliance as No

I selected the service for which i need to create the wsdl.
I got the wsd created with a document with Request and Response. I found the icon View WSDL file on the top right corner. But when i clicked it the interner explorer cannot open it. It shows a page cannot be displayed option.

Can you please suggest.
Thanks,
Krithiga M

Typically as default setting WSDL url only have hostname and port name for IS instance… enter the complete url (including your dns server) alternatively when you create the WS decriptor… there is a setting for END point url there you can specifiy to use like localhost/ip/hostname etc.

try it out… it should work for you!

-nD

yep, you can use the same host like when you go to the administration panel with http://HOST:PORT[/u]

[URL]and like devexpert just said “it should work for you” :wink:

hi nd and aruna,
Atlast i managed to get the wsdl.
But i had to slightly change the URL and i could not get the wsdl directly either on clicking the icon at the right corner or by using the URL (both are the same).

So, i have got the wsdl now but only when i do some changes in the URL with the host information.
Even if i give the correct host information in the host box when prompted, it is changing automatically once the web service descriptor is created.

The problem is solved temporarily but i could not spot the reason for this happening…

Anyways thanks to both of you.,

Regards,
Krithiga

I’m new in webMethods and i’m having some problems with WSD.
I’ve created a Portlet Application Project and i dragged into my portlet’s view.
The problem is that when the webMethods Integration Server’s ip change i’m not able to call the services.
I used the alias to when i generated the WSD for an existing flow service but the WSDL URL point to the old ip

I’m using webMethods 8.2
Can anybody help me ?

Regards

Do you know why they have changed IP and is it normal in your network?

Yes you may to regenerate WSD’s if the IP/URL endpoint changes.

HTH,
RMG

I’m using a virtual machine for the development and i don’t know why sometimes the ip change.
The WSDL URLs of the services on the integration server are updated automatically.
Do you know if exists any way to update the generated wsclient on the portlet project ?
In my opinion a work around for this issue is to configure the wsclient.endpointAddress from the configuration panel of the MWS but I’m not sure if it works.

Regards

You should edit the WSDL file to change the Address location with a proper IP/name.
The locally extracted IP is not necessarily the IP your client will call. When you deploy the WS to different environments, IP changes too.

Yes the IP may changes as you move to different environments (not on same host or same host just port changes) and then WSD updates have to happen but unless you are using web service alias the end point configuration on your IS Admin --> Settings > Web Service Endpoints when you created WSD’s as a provider you don’t have to update WSD’s.

HTH,
RMG

Hi Krithiga,

Have you solved this issue or not?

If not follow this steps:
1. Create a web service descriptor type provider.
2. Create a web service descriptor type consumer based on the provider descriptor. You can get the url in the provider WSDL URL property so if any change in the WSDL happen you do not need to replicate changes into a local file.
3. If you want to change the host information and avoid changes in the url the you should create a port alias in IS, add the detail to the provider binder and then regenerate the consumer.
4. Test.

Personally I will choose the SOAP UI tool to test a web service which is by far more appropiate.

Regards
Douglas