Webmethods trigger is not retrying

I am just trying to let a service retry whenever a transient error pops up. I have followed the guide (https://techcommunity.softwareag.com/ecosystem/documentation/webmethods/wmsuites/wmsuite10-1/Integration_Server/10-1_Publish_Subscribe_Developers_Guide.pdf), but its still not working.

This is my flow:

  1. I publish a user
  2. With a webmethods trigger i invoke my subscribeUser service
  3. In my subscribe user i try to insert the user into a database with an adapter in a try sequence
  4. In my catch sequence i throw a throwExceptionForRetry

When my adapter connection is enabled everything is working fine, when i disable him i would like my user to be retried, but this isnt working. I have tried alot of settings already, these are my settings right now:

retry until: max attempts reached
max retry attempts: 0
retry interval: 10 secs
on retry failure: suspend and retry later
resource monitoring: flow:monitor

In my monitor service i always return isAvailable as true (just for testing purposes)

Hi,

have you tried different values for “max retries”?

I think that “max retries”=0 means no more retries possible after first execution.

You might find additional informations in the Service Development Help Guide.

Regards,
Holger

I think that after 0 retries, the integration server will look at my monitoring service, which will return true, so my first service should do a retry.

(I also tried to put it on another number like 5 retries, but it still didnt work :slight_smile: )