webMethods default password change for Administrator user

Hi,

we are on wM8.2 version, i recently updated the password for Administrator user on the Admin console.

i see following errors in our logs.

[703]2012-01-20 10:27:08 CST [ISS.0053.0002C] Access denied for user Administrator on port 5562 -> ‘wm-message’ from 1XXX.0.0.1.XX

what else needs to be changed as part of Admin password change?

Thanks in Advance.

Sandy.

What OS/Java JVM are you using 1.6?

Are you seeing any JAAS authentication errors in the error logs apart from access deined?

Ofcourse you can able to change the IS Admin default password via user management and relogin the same:

HTH,
RMG

Thanks for the response.

We are on Windows server 2003 Enterprise edition. Jvm version: 1.6.0_24 (50.0)

i didnt notice any JAAS authentication errors in server or error logs.

components we use are IS, Broker, TN.

If you are not able to access IS Admin user I don’t think you can be able to access unless you remember exact password or any typo during password change?

Also editing IntegrationServer/config/users.cnf file might not help.

Did you tried using any other user having Admin rights and so can change the Admin password…I am sure you might have thought on this and just making sure to bring this dumb question:)

Better check with SAG support on this to resolve:

HTH,
RMG

Is someone or something try to use the old password?

Good point Rob and was thinking on the same lines or some one tried entering wrong password or MWS server settings to IS access or remote server sessions and there are various reasons this error could be seen and thus getting in the logs:

HTH,
RMG

Hi All,
After changing Administrator password for IS, I am not able to see service audit in MWS. Monitoring-> Services tab. And when I check IS server logs its showing "Access denied for user Administrator on port 5555 -> ‘soap/rpc’ from 172.11.31.88".

Regards,
Niteesh

Hi All,

Just a quick question(I donnow maybe a dumb one) .But is it possible to change the Admin Password for IS only without changing MWS password?
I tried it but MWS soap calls were getting “access denied”.

Thanks again,
Niteesh

You may need to change the password configuration value at CAF run time configuration and at System settings–> Task engine

Are you saying for IS only or MWS task engine?

Niteesh,If you want to change IS Administrator password can’t the IS Admin User Management can be done right?

Yes, but we are using MWS for service monitoring purpose…

-Niteesh

So what password are you trying to change IS or MWS admin?

Only IS admin. I changed successfully without changing MWS password. Then, when i tried to access MWS -> Monitoring-> Services , i was getting error. IS was denying access (Access denied, soap/rpc) from MWS user.

After that i changed MWS password too with same IS(New) password, it worked fine.

-Niteesh

I am still don’t understand why it is linked with that?..Is your IS/MWS both use AD?

Me too did not think there was. But error was shown in IS server.log when MWS tries to access IS service audit data via soap calls, its authentication was failing. I checked saml and it was fine as before. But still i think there might be something i missed while changing IS password. Weird thing is when i clicked on ESB link, it was showing IS admin properly. Problem was with only soap calls to IS. Maybe some portlet config in MWS causing problem,but due to some reasons, i couldnt follow up on that later.

-Niteesh

ok thanks for the more clarify notes:

Hi Niteesh,

Maybe you need to change the properties of the wmmonitor package. We have to provide the username/password for connecting to IS in that. MWS call the services inside this package.

HTH

Thanks and REgards,
Ninad Patil

Yes Ninad. I am aware of that and we need to do that for WmTaskclient also if we use that.

-Niteesh