Webmethods 10.11 IS SOAP process issue soapenv:MustUnderstand

What product/components do you use and which version/fix level are you on?

webmethods 10.11 IS

Is your question related to the free trial, or to a production (customer) instance?

webservice descriptor worked on 9.12, after upgrade to 10.11, not working. the SOAP message was rejected by IS with the following error:

HTTP/1.1 500 Must Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Security
Content-Type: text/xml; charset=UTF-8

<?xml version='1.0' encoding='UTF-8'?>soapenv:MustUnderstandMust Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Securityhttp://100.77.129.155:5555/ws
        <webM:className>org.apache.axis2.AxisFault</webM:className>
        <webM:message xml:lang="">Must Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Security</webM:message>
    </webM:exception></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

What are you trying to achieve? Please describe it in detail.

how to let the soap message working the same as on 9.12 IS

Do you get any error messages? Please provide a full error message screenshot and log file.

WMERROR.log file entry

f9a12c91-3a02-4fae-836e-8bd5f1fb75a2 f9a12c91-3a02-4fae-836e-8bd5f1fb75a2 3bc82a22-499f-c61b-aa39-01dc7d7660dd nlap041:5555 2022-10-26T15:03:49.765Z 2022-10-26T15:03:49.765Z Must Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Security org.apache.axis2.AxisFault: Must Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Security
at org.apache.axis2.engine.AxisEngine.checkMustUnderstand(AxisEngine.java:108)
at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:173)
at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:172)
at org.apache.axis2.transport.http.HTTPWorker.service(HTTPWorker.java:311)
at com.wm.app.b2b.server.wss.HTTPTransportListener.doService(HTTPTransportListener.java:278)
at com.wm.app.b2b.server.wss.HTTPTransportListener.process(HTTPTransportListener.java:142)
at com.wm.app.b2b.server.HTTPRootWebServicesHandler.process(HTTPRootWebServicesHandler.java:79)
at com.wm.app.b2b.server.HTTPDispatch.handleRequest(HTTPDispatch.java:218)
at com.wm.app.b2b.server.Dispatch.run(Dispatch.java:390)
at com.wm.util.pool.PooledThread.run(PooledThread.java:127)
at java.base/java.lang.Thread.run(Thread.java:829)

Have you installed all the latest fixes for the products and systems you are using?

yes