Want to remove EDIT MASK on a field and also want to change the Datatype of the field

Hi ,
I am Beginner to Naturals. Can any one pls help me how to remove the EDITMASK present on a particular Field and also how can i change the datatype of that field( From Numeric to Alpha Numeric).

Thanks in Advance!!!

More information required …

Is that field defined in a data area, or in a program ?
Do you want to remove the edit mask from a field on a map ?

Yes it is defined in a map…

I Tried to do the following by going through a PDF which is present in the Software AG Site…

.E on the field which i want to remove the EDIT MASK, then im able to remove the EDIT MASK by deleting the values present in that EM Field under the attribute definitions.

I am able to change all the other things except the DATATYPE of field. I tried almost all the ways but not able to change the datatype of that variable… Please help me out in this…

I assume the field in question is imported from a Program or data area,
you will need to change the data type there first.

But, when this is also a database field you’ll need to start THERE.

Hi ,
Thank u very much for the reply… :slight_smile:

I think this is defined from another program… there is a variable against CV attribute in the MAP…

Can you please let me know how to edit particular Program or DATAAREA or Databse regarding this?

If the field is a database field you will have to talk with your DBA regarding whether the field format can be changed (presumably there are other users). You could also check with the person(s) who will be using the map. Perhaps they can be convinced to pass a different formatted field.

If the field is just a simple variable, you need to talk with whoever wrote the specifications for the Map to see if the format could be changed.

If all you want to do is change the length of a field, you could use the AL or NL parameters.

Exactly what is it you want to change from and to?


Hi Steve,
Thanks for the Reply!!!

My actual problem is,
In a Map, i need to change the DATATYPE of a field. I think this field is defined from some other GDA or PGM. My Problem is how to locate from where that particular field is defined from? Whether its GDA or LDA or Some other Pgm. Is there any way to find the origin of the field definition…

I searched almost all the ways… but not able to locate frm wr the definition has made…
Pls help me out in finding the origin of this definition.

Thanks in Advance!!!

The map editor does not keep a reference to where the field has been imported
from, so you will have to use the Natural SCAN command to find the origin.

Okay Thanks a lot for a timely reply!!! Will try to find… :slight_smile: :slight_smile:

I don’t know if this helps, but…

When you import a field from a data area or program onto a map, the map editor flags that field as imported and prevents you from updating the datatype, as you have discovered. If you simply change the name of the field in the field editor that will remove the flag and allow you to change the datatype. Once you have changed the name, you can change it back to it’s original name.

You still need to track down where the field is defined and update the datatype there or you will get a parameter conflict when inputting the map. The field must be defined in the module that invokes the map, so you could start there. It will either be defined locally or in an data area used by that module.