Validation on Broker

hi guys,
does any one have any idea how to stop validation on Broker.
i am trying to publish a Document of Broker,
i already check the Broker Admin and i can see Document type associated with it ,and its already validation is ‘NONE’
but i am still getting this error .
does any one help me out with this.

RMG did you used Broker in your integration and did you experience this kind of Issue before?

[ISS.0098.9007] Data does not conform to the Publishable Document Type ...** errors: INVALID
List of errors:
[0] pathName=/InvoiceList[0]/ns:Invoice/ns:InvoiceHeader/ns:InvoiceNumber errorCode=VV-005 errorMessage=[ISC.0082.9034] Field is absent, field must exist



What you have to do is In the publishable documentType(Invoice)
rightclick on the InvoiceNumber field and select properties and see the tab Constraints there just uncheck the “Field must Exist in the runtime” and save the documentType.

Actually this will be checked automatically when you create the doctype using DTD/Schema if any validation is set.

So the Broker will not look for this particular field when the doc publishes,same thing applies for all the other fields which you dont require validation.


Right ,but its like 6000 lines in that document which i am using
and more over some of the fields are required and there is no way to
un-check the “Field must Exist in the runtime” .(bus they are not active)

I don’t know why if i kept the Validation ‘None’ why its still validating.



Sorry at this point i dont have idea about that behaviour for Validation NONE.I will let you know if any clue.

Other thing is i believe you might have created that IS publishable documentType(OAG INVOICE BOD)based on the DTD/Schema,so you have to set that particular fields Min Occurs to 0 instead of 1.So when creating the documenttype the “Field must exist in the runtime” will be unchecked automatically.