User Task not queued in BPMN Subprocess

Hi all,

I’m working on a BPM process where I need to have a Subprocess that could be repeated.
Inside the Subprocess I have a User Task. When the Subprocess ends, based on some condition the main flow could either end or go back to some steps, leading to the Subprocess again.
When the User Task step inside the Subprocess is reached again, I have the issue:
the process correctly stops, waiting for the Task to be completed; but there’s no Task in the user Inbox. Monitoring the process instance, I found out that this second iteration of the Subprocess does not queue a new User Task instance, but keeps referring to the already completed one instead. So there’s no way to go on, since the process is waiting for the completion of an already completed task.

I’ve noticed this issue working on a 9.7 environment, but I was able to replicate it also in a 9.5 one.
Since I have a complex process, I drew a new simple flow (Start->Step1->Subprocess with User Task->back to Step1), just to check, and the issue was still there.
I also tried to apply an explicit loop expression to the Subprocess, instead of the implicit loop I have in my flow, and the issue kept coming.
If I switch from BPMN Subprocess to webMethods Subprocess, the issue appears to be solved, since a new Task instance is properly queued. Nevertheless, switching to webMethods Subprocess is not a option in this case, not only because they are deprecated but also for design reasons.

Did anyone already face this issue?
Am I missing anything?

Any help would be appreciated.

Hi Fabio,
It seems like Product bug ,Did you created SI ( Support Incident) for SAG ?

Hi Rohit,

sorry, I was out of office in the meantime.
We just created the Incident, let’s see.


Hi all,

just for the record, it turned out to be a bug.
SAG Support suggested us to change the subprocess for a call activity instead.
I’m posting it in case someone faces the same issue.