User Task always generated by Administrator

Hi,
quick question: How can I start a user task which is not generated by Administrator?
I’ve build a Portlet in which a publish ist called. This process starts another process in which a user task is started.

It works like:
user starts portlet -> portlet starts process (A) ->process (B) --> in B user task is startet

More detailed explaination:
I want to use the Service ‘searchTasks’ which is localized in ‘WmTaskClient\pup\task\taskclient’. With the help of this service I want to filter all the tasks which are generated by a certain user (example: testuser).

  • In MWS is created a new user called testuser.
  • In MWS\Public Folders I created a new Site in which the Portlet which is used to publish a new document (–> start a new process) is placed.
  • Now I log in as testuser and use the portlet. After that I use searchTasks whith the parameter user = testuser.
  • The result is an empty resultset. After a quick analysis I found out, that allthough I used the portlet as testuser, my user task was generated as ‘Administrator’.

I hope my explaination is more or less understandable. Can someone help me fix this?

Thanks and best regards
Stefan

Hi Stefan,

Once the task is generated by administrator you need to re-assign the task to your testuser, then only when you search for a task related to testuser will be able to find some results.

Hi Prateek,

thanks for your reply :slight_smile:
Is there no way to generate the task as testuser? I also tried re-assigning the task. After starting the process by using the portlet as testuser I switched to myWebMethods Administrator an tried the following things:

  • Assign to testuser
  • Acceppt for testuser
  • Delegate to testuser

But ether way using the service searchTasks with input name = testuser resulted only in an empty output :frowning:
Do yo maybe know another way to assign a task to a specific user and then get a list of all tasks which are assigned to this user? Or do I use the service “searchTasks” the wrong way?

Thanks again for you help and best regards!
Stefan

Hello again,

so far I’ve worked something out. It’s not perfect yet:
For generating a new user task I use queueTask (also localized in ‘WmTaskClient\pup\task\taskclient’). The Input Parameters are testuser as username and the task type ID. Now I have a new user task which is created by “testuser”. The next step ist building a flowservice which filters all tasks I get from ‘searchTasks’.
After that I generate WSD for this flowservice an build a Portlet.

Now I have the following problem: My flowservice needs a username as input. But it would be much better to automatically fill this input value. Is there a way to fill the textinput of username with the principalID?

I’ve attached a screenshot to (hopefully) make everything clear.

I’m open for any suggestions! :slight_smile:
Thanks and best regards
Stefan