Unable to start Integration Server (IS)


I am unable to start my 9.6 IS, till last weekend it worked fine, but from yesterday its not coming up, no logs are getting generated with startup.bat command.

I tried safeboot option too, nothing is happening. As soon as I execute below command, another windows pops up and gets closed within in 3-5 seconds, unfortunately nothing is getting written over there to get a clue.

…/bin> startup.bat

…/bin> startup.bat -safeboot -log trace

…/bin> startup.bat -safeboot

Tried replacing config files from the backup folder too but still no success.

Any idea, why is this happening. Did any one of you faced it earlier?


Any messages on server.log ?


I can’t see any server.log generation, in fact none of the logs.
I have absolutely zero visibility on this issue as there are no log files since beginning of this problem. It’s really strange, I have never seen such scenario. Luckily it’s a dry run environment, so no impact at this point of time.


Issue is resolved after removing wrapper.anchor & .lock file.
With 9.6 version, wrapper.anchor file has been introduced


Can anyone shed some light regd the imp of wrapper.anchor file ?


Glad to hear that you figured the issue by yourself.

Tanuki wrapper creates an anchor file on startup. The Wrapper will monitor the file and then shutdown when it is deleted. The Wrapper can still be shutdown by normal methods. If the anchor file still exists when the Wrapper shuts down, it will be deleted automatically.

For detailed information you can browse http://wrapper.tanukisoftware.com

Regarding wrapper.anchor file I got help from SAG :slight_smile: