Unable to send message to JMS provider

Hi Guys,

I created a JNDI Provider, Connection Factory and Destination in My webMethods Administrator console (Administration > Messaging > Naming Directories).

Then in Integration server - configured JNDI alias, JMS Client Connection alias and enabled it.

In a flow service, I then called pub.jms:send service to send a JMS message to the above configured destination. At this step, I’m getting below error -

[ISS.0134.9009] Unable to send message to JMS provider "wmNativeConnection": com.wm.app.b2b.server.jms.JMSSubsystemException: javax.jms.JMSSecurityException: [BRM.10.5001] JMS: No send permissions for event type "JMS::Queues::test_dest_queue" in client group "JMSClient"

I can’t see any document type “JMS::Queues::test_dest_queue” created in “JMSClient” client group.

Could you please advise how to grant the required permissions to resolve this issue?

webM version - 7.1.3

Kind regards,
Raj

On MWS go to Administration -> Messaging -> Broker Servers -> Client Groups

  • Locate the "IntegrationServer" or IS-JMS client group and enter into its details
  • In its "Can Publish" and "Can Subscribe", add the document types you will be handling. Usually you should have defined these document types as Topics in Administration -> Messaging -> Broker Servers -> Document Types before all that.

Hi Raj,

are you using Topics or Queues?

Queues have to be created under Clients, Topics are created under DocTypes.

Which JNDI Provider are you using? (wM JMS Naming vs. FlatFile)

There have been some issue with the JMS connectivity in the past, so please make sure that you have latest Broker Core Fix, Broker Java API Fix and Broker JMS API Fix applied to all your Broker, IS and MWS services where applicable.

Additionally you should forward the JMS API Fix to you partner systems (if any).

Regards,
Holger

Raja,If I understand correctly, you are going to use topics as part of your interface. Follow what Mahes specified which looks okay to me also follow instructions given by Holger. If still problem persists kindly share your package along with MWS snapshots.

Thanks,

Hi Guys,

Thanks for your replies. This issue is resolved to me now.

Created Queue under Clients and added it to Can Publish / Can Subscribe list in Client Group IS-JMS. This allowed me to send and receive JMS message over Broker JMS Provider.

Glad to hear :stuck_out_tongue: