Unable to send message to JMS provider - Invalid object type for Message field

Hello

We are trying to send bytes (Java byte[]) in a JMS Message, however, we have the following error message :

[ISP.0090.0003C] [ISS.0134.9009] Unable to send message to JMS provider “ConnectionJMSAdmin”: com.wm.app.b2b.server.jms.JMSSubsystemException: javax.jms.MessageFormatException: [BRM.10.1005] JMS: Invalid object type for Message field: “donneesObject”.

The message field donneesObject is set to have the Java Wrapper Type : byte []

And we set the value of donneesObject in Java with byte []

Our IS is in version 8.2.2.0 with the following fix : IS_8.2_SP2_Core_Fix10

Thanks in advance for your help

Regards.

are you still facing issue. can you please share screenshot of your pub.jms:send service invoke.

Hello

Yes I am still facing the issue, I still haven’t found a way to send my bytes in the properties and not in the body.

Attached is the requested screenshot.

I tried putting my bytes in the body/bytes field, I do not have the error message any more but unfortunately our consumer reads in the properties, not in the body.

Thanks in advance for your help.

Did you try mapping donneesObject to JMSMessage/body/bytes and test?

Yes I tried and it works, I do not have the error message anymore BUT the problem is that the JMS consumer we have uses the JMSMessage/properties and not JMSMessage/body

Is there any way to send bytes in JMSMessage/properties ?

Thanks in advance

I am curious to know the use case. if it application data why client maps it to properties.i have never come across such situation. webMethods JMS is like any other JMS. look up JMS api and see if bytes are supported to be sent as properties, i fear answer is no.

Hello

As I said, the problem is that I am working on an already working project in which the JMS consumer reads all the datas from JMSMessage/properties and not JMSMessage/body.

However I read the JMS Message specification (http://docs.oracle.com/javaee/6/api/javax/jms/Message.html)

and it’s clearly stated that :

 |        | boolean byte short int long float double String 
 |----------------------------------------------------------
 |boolean |    X                                       X
 |byte    |          X     X    X   X                  X 
 |short   |                X    X   X                  X 
 |int     |                     X   X                  X 
 |long    |                         X                  X 
 |float   |                               X     X      X 
 |double  |                                     X      X 
 |String  |    X     X     X    X   X     X     X      X 
 |----------------------------------------------------------
 

So I don’t see why I could not send bytes in the JMSMessage/properties

If someone can help me !

Thanks in advance

Regards