Unable to publish

Hi,
I am having problems publishing a document locally.
Document doesnt get published and i get 2 server error log entries (pasted below).

Can anyone help me with that?
Thanks,
Ouri.

[ISS.0098.0082E] Unable to persist Document: melCanDocFolder.ServMelittaDomainScoring:CanDocMelittaDomainScoring to Document Store: ServMelittaDomainScoringFolder:TriggerScoring. Exception: com.wm.app.b2b.server.dispatcher.exceptions.PersistenceException: com.wm.app.store.TSException: [BAT.0002.0000] Wrapped Exception: java.lang.IllegalAccessError: try to access class com.wm.util.data.TxnData$Cursor from class com.wm.app.store.impl.TSMessageStore

[ISS.0098.0024C] No Trigger available for incoming Document melCanDocFolder.ServMelittaDomainScoring:CanDocMelittaDomainScoring. Rejecting Document

I am having the same problem. When a publish a document to the broker my trigger works fine. When a publish a document locally, however, I receive the same error as Ouri. Suggestions?

Fred

Set the service’s pub.publish:publish 's input local to true or try to remove any setting there.

give that a try

Thahir

Hi.

I am also getting the same error. Has anyone managed to resolve this problem? We have no broker installed, so according to the documentation, all publishes become local. The local flag had been left unset for the pub.publish:publish service, and I tried setting it explicitly to true, but still get the same error.

Thanks.

Ian

Hi.

I’ve figured out what the problem is. The Document Storage Type was set to Volatile. When I changed the Storage Type to Guaranteed, the document is published successfully with no error in the log.

Ian

Hey Friends,
Even After setting the document storage type as Guaranteed, I am getting the same error.

To be more specific to the problem, the error message I am getting is:

2004-11-22 16:52:33 CST [ISS.0098.0024C] No Trigger available for incoming Document XXX. Rejecting Document

2004-11-22 16:52:33 CST [ISS.0098.0082E] Unable to persist Document: XXX to Document Store: YYY. Exception: com.wm.app.b2b.server.dispatcher.exceptions.DupeMsgException: com.wm.app.store.TSDupeMsgException: [BAT.0000.0032] duplicate message for store id YYY in parent container id TriggerConsumer

I guess It might have happening because of sending the duplicate messages. But I want the trigger process the duplicate messages,too.

Any help will be highly appreciated.

Regards,
Nilesh

Hi Nilesh.

Check out this post.

http://www.wmusers.com/wmusers/messages/117/26429.shtml

Hope that helps.

Ian

Hey Ian,

Sorry I missed to inform you guys that I am working on IS 6.1 and I have configured an MQ Listener. Whenever MQ listener finds a message on the queue, it notifier IS via a Notifier. Notifier publishes the document and trigger invokes the flow service.

I appreciate your help but i did read that post earlier and it seemed to me as IS 602 fix. And as i said earlier i m working on IS 6.1.

If you say that even then I have to install that fix, then i will try to…

Thanks,
Regards,
Nilesh

Nilesh,

Check whether document is published to broker, goto WmBrokerAdmin page, then check for document in respective broker in respective broker server.
if document is published, then check the Name/Type of the document you are subscribing in trigger.
if document is not published, then go to DEVELOPER->File->Sync Document Type->All out of sync.
push all out of sync document to broker and then test trigger.

even i have almost similar scenario, but things are working fine for me.My environment:IS 6.1,WinXP,MQ Adapter.

Regards,
Puneet Saxena

Hi Puneet,

Thanks for taking interest in my post and posting the reply.

But I missed again to write in the post that the documents are published locally to IS. I have no broker configured. All the inbound documents are published to IS locally.

Regards,
Nilesh

Hi Nilesh,
Sorry for being bit late in replying.

kindly check whether you are giving fully qualified publishable document name in trigger?

In my scenario, my trigger is subscribing a adapter notification publish to broker, and not to local IS.
Altough i tried with stoping my BrokerServer, and then replicating it but the error i got was different :

" 2004-11-25 12:08:19 IST [LGU.0002.0001E] Error getting broker log length: Unable to open connection to host ‘localhost’. Error ‘java.net.ConnectException: Connection refused: connect’ was reported by the socket call."

Which clearly say, it’s brokerserver that was stopped.

but if i use any publishable document(not adapter notification) it gets published to local IS and trigger is working fine …

For reference about trigger read “PublishSubscribeDevGuide.pdf”.

Regards,
Puneet Saxena