Unable to publish the document locally

Hi,

Currently I am using webMethods 9.8 trial version. To my knowledge, the Broker is deprecated from 9.7 release.
It is replaced with UM Realm server.

However, when I tried to publish the document locally, the pub-sub functionality is not happening. The subscribing trigger is not getting fired, eventually the subscribing service is also not getting invoked.

I must have to make the Realm server up & Running, and IS_UM_Connection (Default Realm server connection) enabled to do any publish activity.

Can’t we do this Pub-sub locally, with out UM?

Hi Srinivas,

I think Broker 9.6 is supported to be used with other products of 9.8 release. It is not yet deprecated, but instead no more new enhancements (or releases) are done on that further. But in future UM will replace Broker.

Since 9.7, the default messaging has been changed to UM in all products. But if you still want to use Broker with them for messaging, you can do so by adding new connection to Broker or modify existing one pointing from UM to Broker from IS > Settings > Messaging page.

HTH,
Chandra

Srinivas/Chandra,

webMethods Broker

  • last version is 9.6, and not 9.7
  • supported until October 2020
  • not deprecated yet

Reference: https://techcommunity.softwareag.com/techniques-blog/-/blogs/webmethods-broker

Back to your question… Local publish is to do with Integration server. Have you set local to ‘true’ explicitly, while invoking, pub.publish:publish service?

Regards
Senthil

Thanks Senthil for correcting me. Updated my answer

Hi Senthil,

For doing local publish, I set the local to “True” explicitly for the pub:publish service and tried to publish the document. However, the subscribing trigger and the subscribing services are not getting invoked.

I am not getting any error.

Go to Settings > Messaging > webMethods Messaging Settings > Change Default Connection Alias, select “LOCAL ONLY”. Check if IS restart is required.

Srinivas – Can you share logs before and after using publish service, did you see any hints there.

Thanks,

What Mahesh have mentioned is totally correct.
If my default message provider is set as UM and trying to publish as locally true,then also IS is trying to publish the document through UM only.So,in this case published document is getting stored in CSQ of UM.So if default message provider is set as UM then ,there is no importance of locally value in pub:publish service.I think,it may be a product bug.

Apart from that,If I turned default provider to “locally only” and then disable/enable publishable document and trigger properties to sync up publishable document and trigger then also it is not working unless IS server is re-started.And after IS server re-start with default publishing as “locally only” there is no need to set locally value in pub:publish.What ever we publish will go publishing mode locally only.

Thanks
Baharul Islam

Are you sure you wrote the value correctly? Shouldn’t it be spelled as “true” (no capital “T”)?

I do not think so. :slight_smile:

The input should be a “list of choice” like a drop-down.

Thanks all for your replies.

As Mahesh said, I changed the default message provider alias as “Local Only”, then my local pub-sub functionality worked perfectly.

Anyway, as Baharul said, I see no importance in setting pub.publish service locally value. As, I need to change the default message provider alias instead of setting Locally value in pub.publish service to publish locally/UM.

Thanks,
Srinivas M

Thanks Srinivas for updating, it is useful to other members.

Thanks,

Yes of-course :slight_smile: It is documented and as per the design. For more details refer Pub-Sub Developers Guide.