Unable to find the SAP Tab in the Adapters at the AdminConsole

Hi all,

  I have a strange problem faced today when I logged in to SAP-BC 4.6 AdminConsole.
   I was not able to see the Adapters-->SAP tab and I also lost the Routing rules defined in the Development server.

  I am just not clear as to what have happenned. Can we find anything in the logs in this regard? we have tried but were not able to track them.

Kindly suggest me how to revert back the changes done to the server if done by anyone..

 Kindly suggest me as early as possible.

Thanks in Advance,

sorry for missing…the Environment-Info, we are working is WindowsNT/SAP BusinessConnector 4.6.We also try to connect from the SAP system using the previous aliasName of BC,Configured. but not able to…

  so, I think some files got missed...

Donno…what can be done…


Check in Package Management and check if SAP package is enabled. Also in BC, WmPartners package is a dependency package. Check both of them…


hi Bash,

   Thanks for your response.

I have checked the packages(WmPartners & SAP), but they were active. But,there was one package where the routing rules were created, that was the one that loaded partially.

    but when we have made tha package active based on the error message, it got active. then we have restarted the IS.Still  this did not enable the SAP tab at the AdminConsole.

     Just trying with the similar options......

Kindly suggest if you have any clue…

    Thanks again for your response..


Hi Bash and all,

We have resolved the issue by restoring the system for 2 days previous. but as this was a Development& Testing, we could do it.
we have done that, expecting a missing of a file or two with the system…

Understandably, this was not the solution that would be intresting…

can any one throw some light…!!! if they come across the similar problem…?


Hi All,

The same thing happened again…

Today Morning when i came and logged in to he SAP bc Admin console,
I have found again the SAP Adapter lost.

  And when i have tried to restart the Server,It went down.

I cannot restore always…as I did previously,

Just dont know why this has occured again.

Is this thing New to all of you?

If So, Can you try any solution?