Unable to find host blocalhostb on the network


I did run in a rather strange behaviour when installing IS 6.1 with JVM 1.4.2 and broker 6.1 on an AIX 5.1 plattform.

Funny enough things went fine on our testsystem but on the production system I got this strange error:

2005-07-04 01:05:21 CEST [ISS.0099.0003E] Unable to create Broker Transport Exception com.wm.app.b2b.server.dispatcher.exceptions.EndpointUnavailableException: [ISS.0098.9014] BrokerException: Host Not Found (105-1190): Unable to find host ‘localhost’ on the network.

How can it be that the localhost is not found? Of course I am trying to find oput if there are differences between our test and prod system but so far I did not find them.

Does anybody have an idea what is going wrong here?



Check if ‘localhost’ is known by the Operating System (AIX) by entering
the command “ping localhost”.

If you got something like
. 0821-062 ping: host name localhost NOT FOUND
then ‘localhost’ is not declared.

Check /etc/hosts file and compare with the one on the test system.


Hi Francois,

sorry I forgott to mention that this works. Atually I first had this error with other hostnames. But then realised that even localhost was not found.
So one of the first things I tried was to ping all the hosts from the unix command line. This worked fine. Obviously also our older installation with IS 6.0.1 which resides on the same AIX server (but was shutdown when I tried the new IS version 6.1)


OK, we found the reason. We had to upgrade our AIX system.

Erroneous AIX Installation (impossible to enable FTP ports on wetMethos IS and localhost is not recognized.):
5100-04 AIX 5.1 Maintenancelevel (ML) 04

AIX Upgrade (IS FTP ports and localhost work fine):
5100-08 AIX 5.1 Maintenancelevel (ML) 08
Platform Firmware: ROM Level…3F050502