unable to edit processing rule in newly migrated TN 6.1

I am unable to edit processing rule in our new migrated TN 6.1

I am getting below error when I am trying to edit processing rule.


Processing rule update failed. Processing rule update collision detected. This rule has been modified by another user.

I tried this with Administrator user.

Please help me in resloving this issue.

Search the knowledge base for this and you’ll find your answer.

Basically, there’s a migration script for the TN DB that either you didn’t run or it didn’t work when you ran it (this seems to be happening an awful lot, wM guys). The script is supposed to initialize a new column that got created in one of the TN tables in 6.1 called lastChangedTime, I think. In any case, an easy workaround is to export and re-import all the rules that exhibit this problem. The import process sets the value for lastChangedTime and you won’t get any more collision detected messages. This worked for me.

If you don’t want to do this, check for the name of the script in one of the closed SR summaries in the knowledge base and re-execute it, being careful to ensure it works.

Mike Rossi

We have seen this msg with 2 servers sharing an Oracle DB for wM TN.

Sometimes the updates on 1 server do not make it to the other server in a timely fashion. I know a server reboot has cleared the problem.

Did you check your clustering configurations. For a quick fix, try executing “wm.tn.route:load” service. Let me know if this works.

Hi Usha, we are not using Clustering Env. I tried with wm.tn.route:load the service, still getting same issue.

I did not get any error while running the scripts .I can’ t import the processing rule as it is in production and also working good, only thing is unable to edit the processing rule.

please help me.

There are half a dozen closed SR summaries on this in the knowledge base. Here’s the text from one of those:

“This problem occurs if the “lastchangeid” for processingrules table is not populated. As part of the migration step documented, step 6 asks you to run migratedata_to_tn_6-1.bat. That is the step that populates this column. Looks like customer had skipped that step.Once we ran the scripts again, the problem was resolved.”

If the script didn’t populate this column for some reason and you can’t re-import the rules, maybe you can examine the script and the affected table (noting the data type of the new column in particular) and manually add the missing data. No matter how you do it though, you’re going to have to get this data populated. Best of luck.

Mike Rossi

Hi Mike Rossi, Thanks for immediate Responce. I am completed succesfully everything whatever in the Migration document. Issue is resolved now. I exported & imported same processing in the same server, then I am able to edit all processing rule. deleted the duplicate processing rule which was imported.

You know one thing, I am getting error while inserting processing rule

( error: Error encountered while inserting processing rule 1unaqh0012d20ji1t0000001i. The exception message is : [wm-cjdbc33-0069][Oracle JDBC Driver][Oracle]ORA-01401: inserted value too large for column.

(0) java.sql.SQLException: [wm-cjdbc33-0069][Oracle JDBC Driver][Oracle]ORA-01401: inserted value too large for column

(1) java.sql.SQLException: [wm-cjdbc33-0069][Oracle JDBC Driver][Oracle]ORA-01401: inserted value too large for column

but when I am trying to insert same thing in other system, I am able.

its really crazy with TN, something is not working in my machine and samething working in other machine.

Thanks again,

Do you have the fix TNS_6-1_Fix15 installed on the sever you are having this problem? If not, you need to apply this fix. This is one of the critical fixes for TN 6.1.