Unable to create document from 46Broker document type in 61

I am trying to create a document in 6.1 from 4.6 broker document type.The document gets created with the “Broker doc type” as a temporary IS document type (wm::is::foldername::documentnametemp1) whereas I am expecting the type should be 4.6 broker document type (folderName::documentTypeName).Using brokeradmin I deleted the temp IS document type,reimported the 4.6 document and tried again still no success. Any help would be much appreicated.

Why do you refer to wm:is:foldername… as a “temporary” IS document type?

This is the normal naming convention for a broker document type created from an IS publishable document on 6.1.


I agree, however the document name has “temp1” suffixed at the end. Also this document type never existed in IS. It gets created while I am creating a broker document type from 4.6broker document type.

Yes, this is the normal behavior.

Here’s how you can see this for yourself:

Create a brand new IS document type on 6.1. Then set publishable to TRUE.

You will see that the Broker doctype has the same wm:is prefix.

Are you just wondering why things look different, or is there another reason that you are concerned about this?


Thanks Mark for the response. I am creating the broker document type from existing4.6 broker document type, so the “Broker doc type” field in the properties should really be 4.6 document type (of the form folderName::documentTypeName) not the 6.1 IS document type (of the form wm::is::foldername::documentnametemp1).