Unable to connect to JDE

Hi ,
I have Installed JDE XPI Oneworld Adapter , i did the following steps

  1. edited interop.ini
  2. created relevent log files
  3. added kernal,connector,oneworld.properties and interop.ini

C:\Apps\wment41\lib\jde_OneWorld_Adapter\45\connector.jar;C:\Apps\wment41\lib\jde_OneWorld_Adapter\45\kernel.jar;D:\B7\System\Classes\repository;C:\Apps\wment41\lib\jde_OneWorld_Adapter\45\properties\OneWorldAdapter.properties;


  1. I also set the classpath in adapter conf tool’s java tab
  2. when i try to run the adapter in the debug mode iam getting the following errors

4:35:23 PM [Adapter] (085) The adapter process could not start up.
4:35:23 PM XPIe OneWorldAdapter: (804) J.D. Edwards OneWorld reported the following error:
4:35:23 PM Remote environment initilization failed. Plz see Enterprise Server log for details


kindly help me

thanks in advance

That’s a generic JDE error that could mean a lot of things. The most common is that your username/password isn’t valid for the JDE environment that you specified in the interop file. If that’s not the problem, then you need to have your JDE admin look at the server log - there should be a detailed error message to tell you what’s really wrong.

Hi Anush,

The problem is not with tracking infosets (anytime when an adapter is being used for the first time you can get that message… )

Three things might be needed to solve:
First: get your interop.ini verified, check the port, ip of the JDE Enterprise Server
Second: get debugging enabled on the server ( this is tricky, as it slows down the server, but it will help with the debugging later. Once your code gets out of testing, you can get it disabled)
Third: check the server.log and debug.log on the server, and see what’s the issue with it. The server debug logs are normally much more detailed then other logs.

Hi chirag,
thanks for your quick reply. i have check all the things. iam able to connect to JDE through my java program. onething i would like to menthion here .when i run my program it was asking for jas.ini. so i renamed the jdeinterop.ini to jas.ini it worked.

when i tried the same for webmethods its not working. i tried all the possiblities like setting in the classpath,restarting maching … kindly help me…

Which was the application that you executed and it asked for jas.ini? and after that it worked?

where are your .ini file for the adapter placed and what is it’s name?

what are the settings in C:\Apps\wment41\lib\jde_OneWorld_Adapter\45\properties\OneWorldAdapter.properties;

Hi Anush,

««« In response to your port problem 6003»»»»

This means you have multiple JDE adapters 45 configured and JDE is listening to the same port (conflict) for each adapter using the outbound capabilities (only the first or one at a time will work=> if you dont set it properly or individual).

If you dont want to use the outbound capabilities, try to uncheck the logging in the oneWorld tab of your adapter and you’ll be able to have multiple adapters Inbound (using business function).

But if you need the outbound capabilities:
Your Enterprise Server (JDE) is set to communicate by the 6003 port(default) in your jas.ini file :
[EVENTS]
port=6003
ListenerMaxConnection=100
ListenerMaxQueueEntry=100

As long as you have only 1 adapter it will work, but if you have multiple JDE 45 adapters, you’ll need to set a different port for each adapters in a seperate jas.ini file(outbound capabilities only).

I hope my English is good enough to understand (Montreal,Canada ===>French) and it’ll work for you!!!

Jay

Hi,

first thing is: Check the ports used in your config as well as ini file. I have not worked with 4.5 adapter, i have used 1.0 adapter and i do recall that this ini file has to have a specific name and it had to be placed in a specific folder (that time we used to have \wment41 and \active40 folders).

if your java code is working, which means the server is definitely listening for java calls, all that may have gone wrong will be your configuration settings in that case.