Unable to connect to jdbc pools

Hi All,

I have installed wm 7 on my computer and i’m trying to connect to sql 2005 on the same system through jdbc pools. however the test fails with this message: Error establishing socket to host and port: MY-B7787E9C546F:1433. Reason: Connection refused: connect

i have substituted the server name with the IP address of the machine too but it does not work. telnet session to the same server and port also fails with the same error. i have enabled the tcp/ip connection in the sql server and also provided the port number. dont know what else to do… pls help!! counting on you guys!. thanks

“Connection refused” usually means you have the right machine but nothing is listening on the specified port.

Just Check once if you have enabled the database connection to SQL 2005 in Integration Server in JDBC Adapters tab or not.

If that is already done you might be having a port collision Use netsat -a on the command line in a Windows Env.

i havent enabled the jdbc adapters connection. in fact i havent configured it yet. i’m sure sql server is not listening on the port 1433 at all. dont know what else to do.

If you haven’t enabled the jdbc adapters connection , Then how are you having communication of wm with the database.
Are you using a DSP page?

I suggest that you go through the JDBC Adapters guide.
It is self explanatory.
Happy Debugging

Warm Regards
Rajat Bhatnagar

“Give a man a fish and you feed him for a day,
teach him how to fish and you feed him for a lifetime”

If it is not on port 1433 then you’ll want to find out what port it is using and specify that in your configuration.

You may want to review the wM IS documentation to cover the basic setup needs for interacting with a database.

In the MSSQL Server 2005 there has been a change in the way TCP\IP Communication is done when compared to 2000. In 2005 they have provided the functionality of Dynamic ports for TCP\IP communication. While giving the URL for the JDBC pool do not use any specific port number, just leave that blank like this



it worked finally!! i jus rebooted the machine after configuring the ports. initially i was only restarting the database. thanks for all your help!!