Unable to configure JDBC adapter

Hello Wm Folks,
I am using SQL Server 2000 driver for JDBC and I am not able to configure the adapter. I went thru so many threads but could not find a solution for this problem. The errors encountered are

[ART.118.5042]Adapter Runtime(Connection): Unable to enable connection resourse…
[ART.118.5036]Adapter Runtime(Connection): Unable to configure connection manager
[ADA.1.200]The JDBC data source class cannot be located.

All classpath variables and jar files are set right according to the webmethods & SQL-JDBC driver pdfs and I even checked the class names for Driver and DataSource also.They were also given correctly.I am not able to find the problem inorder to fix it.Any help on this is greatly appreciated.

Thanks,
Shelly

Did you use the Microsoft jars? MS Knowledge Base article 313100 describes how to access SQL Server from Java. With the jars and settings described there I got the adapter running without problem.

Thanks Martin,
I did follow that article while configuring my SQL Server Driver for JDBC. I have set all the classpath variables as given in the article. But I still can’t enable my JBDC adapter. Is there anythign extra that I need to do to make the connection manager work and eliminate these errors.

[ART.118.5042]Adapter Runtime(Connection): Unable to enable connection resourse…
[ART.118.5036]Adapter Runtime(Connection): Unable to configure connection manager
[ADA.1.200]The JDBC data source class cannot be located.

Is there anything else that anybody can think of. Pls help

Thanks,
Shelly

Shelly,
Post your JDBC Adapter configuration parameters and env setup details. This will help us get more information on your setup and hence suggest a solution.

  • Saurabh.

Following are the parameters in my JDBC Adapter configuration screen.

Connection Type JDBC Adapter Connection
Package Name custm_JDBC_adapter_conn
Transaction Type NO_TRANSACTION
DataSource Class com.microsoft.jdbcx.sqlserver.SQLServerDataSource
serverName xyz
user abc
password ******
Retype password *******
databaseName Wm_Db
portNumber 1433
networkProtocol tcp
Other Properties
Connection Management Properties

And one more new update to my previous situation is that I installed a SQL Server Driver for JDBC with sp1, prevly I had sp3. After running sp1 driver, one error got eliminated. Now the errors encountered are only the below two.

[ART.118.5042]Adapter Runtime(Connection): Unable to enable connection resource…
[ART.118.5036]Adapter Runtime(Connection): Unable to configure connection manager

I am trying to figure out if I need to write any service to get this running!! Any ideas??

Thanks,
Shelly

What JVM do you have installed? I forgot, we had to install j2re 1.4.2 (or newer). wM came with 1.3 which seems to be incompatible with the SQL-driver.
Make sure to install j2re files in a new directory (default install directory will do fine) and change the path-settings in the config-files IS\bin accordingly.

What version of the driver you have?

Did you copy the driver jar files to the WmJDBCAdapter\code\jars\static folder? Ensure that the driver jars are in the server classpath.

I dont see the need for jre1.4.2 as I have it up and running for 1.3.1; IS 6.1; JDBC Adapter v6.0.3.1; (even though min jvm version for this adapter is 1.4.2)

  • Saurabh.

I have jre1.4.2 and also the driver jar files are present in the WmJDBC package. But still I get the same error. My JVM in integration server is 1.3.1 so I redirected it to another jre1.4.2 directory. It did not make any diff…I am not able to figure out where the problem is coming from??? Any ideas?

Shelly,
as I suggested, you have to put the jars in code/jars/static folder.

Why dont you post your server classpath on the thread. This will help us determine if thats the problem or not!

  • Saurabh.

Saurabh,
I did as per ur suggestions, I did not have a static folder in WmJDBCAdapter/code/jars so i created a new folder with the name static and loaded these jar files in that folder. Now I have the jar files in both IS/lib/jars/ and also in WmJDBCAdapter package. Even that did not make the situation any better!!! I am getting the same ol’ errors. I am pasting my server classpath also below. Is there anything else I need to do.Pls let me know if u need any additional details.

C:\Program Files\webMethods6\IntegrationServer\updates\IS_6-0-1_SP2.jar
C:\Program Files\webMethods6\IntegrationServer\lib\classes\
C:\Program Files\webMethods6\IntegrationServer\lib\server.jar
C:\Program Files\webMethods6\IntegrationServer\lib\client.jar
C:\Program Files\webMethods6\IntegrationServer\lib\mail.jar
C:\Program Files\webMethods6\common\lib\client60.jar
C:\Program Files\webMethods6\common\lib\apiutil60.jar
C:\Program Files\webMethods6\IntegrationServer\lib\jars\msbase.jar
C:\Program Files\webMethods6\IntegrationServer\lib\jars\mssqlserver.jar
C:\Program Files\webMethods6\IntegrationServer\lib\jars\msutil.jar
C:\Program Files\webMethods6\IntegrationServer\lib\jars\sl53_cj32.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmART\code\jars\static\wmartbundle.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmFlatFile\code\jars\static\ffcore.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmFlatFile\code\jars\static\tspace.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmIPRoot\code\jars\static\WmIPRoot.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmJDBCAdapter\code\jars\static\msbase.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmJDBCAdapter\code\jars\static\mssqlserver.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmJDBCAdapter\code\jars\static\msutil.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmPartners\code\classes\
C:\Program Files\webMethods6\IntegrationServer\packages\WmPRT\code\jars\static\wmprt.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmTN\code\jars\static\tncore.jar
C:\Program Files\webMethods6\IntegrationServer\packages\WmWin32\code\classes.\

Shelly,

Everything looks pretty solid as far as the jar file locations are concerned. I have been using SQL 2000 for a few years with no trouble at all.

Two things I would change in your configuration under the connection screen and then you should be up and running:

  1. Remove the TCP reference from the Network Properties.
  2. Under “Other Properties” add the following:

selectMethod=cursor

Everything else looks good. Let’s see what happens.

Ray

Shelly,
Try what Ray has suggested. I will also ask you to try removing the microsoft jdbc driver jars from “C:\Program Files\webMethods6\IntegrationServer\lib\jars” directory just for the heck of it. (this will ensure that classes in sl53_cj32.jar gets precedence over classes in microsoft jdbc driver jars - just in case, if there is any conflict).

After this, let us know if you still get the same error.

As Ray pointed out, everything else looks good. I see you are running 6.0.1 SP2.

  • Saurabh.

Ray and Saurabh,
Thank you for your suggestions. I have applied the points which you have provided me but for some reason I am still getting those error messages. Do u think I am having issues because of my versions…

My versions are :
IS 6.0.1 SP2
JDBC 6.0.3
SQL Server 2000 8.00.194

Thanks, Shelly

Shelly,

The SP2 will not have any affect on your installation.

I wouldn’t remove the MS SQL jar files because the JDBC adapter will not have anyway to connect to the database.

Also, one other thing that you need to check:

If you make ANY changes to the JDBC settings, retype the password in the password spaces, or else you will have problems connecting.

You are using the latest JDBC adapter build, so I see no other problems. I am using the same.

Let me know how this works.

Ray

Ray,
Clarification: I asked Shelly to remove the ms jdbc driver jars from the “C:\Program Files\webMethods6\IntegrationServer\lib\jars” but keep them in “WmJDBCAdapter\code\jars\static”.

This way the JDBC adapter can still reference the class files from the jars in the jars/static folder.

Reason: this will ensure that classes in sl53_cj32.jar gets precedence over classes in microsoft jdbc driver jars - just in case, if there is any conflict.

Shelly,
If this also doesnt work, I suggest that you write a simple java client outside of webM to connect to the same database. This will have webM out of the loop. I think at this stage, it is worth trying.

HTH,
Saurabh.

and yes, dont forget to restart the IS after moving the ms jdbc driver jar files.

  • Saurabh.

Hi Friends,
I am using Webmethods 6.1 and have installed JDBC adapter 6.0.3 on Windows 2000 Professional .JVM ver 1.3.1
I am getting an error while creating new Connection to Oracle

The error message displayed is
Error encountered
[ART.118.5011] Adapter Runtime (Connection): Unable to create new connection first:conn.
[ART.118.5020] Adapter Runtime (Connection): Unable to process connection properties. Internal error.

I have placed classes12.zip in the IS\lib\jars and WmJdbcAdapter\code\jars\static folders

The following are the configuration details that i use for creating new connection
Transaction Type Local Transaction
DataSource Class com.jdbc.pool.OracleDataSource (also tried with oracle.jdbc.pool.OracleConnectionPoolDataSource)
serverName Name of the Oracle server
user uid
password pwd
databaseName pmdb
portNumber 1521
Driver properties driverType=thin

Please help!!

I was struggling with the same issue until I copied \IntegrationServer\packages\WmJDBCAdapter\code\jars\javaxsql.zip into \IntegrationServer\lib\jars and restarted IS, the problem was resolved.