Unable to access admin page 10.7 after cloning IS

Situation: just cloned an existing production IS server to a new one. Attempting to fire up the IS for the first time which seems successful but unable to access the admin page.

Steps taken:

updated remote.cnf file to new host name
run startup.bat
run check_status.bat and ensured IS is running

However unable to open IS Admin page:


Any guesses on why IS admin page won’t load? or other config files to check? Which log file would show any issues? How can I check what the actual host name and port the IS is running on in real time? thanks for any help into this

Please clarify how you “cloned” the server

@daniel.evans , can you please have a look @ server.log and Error logs to see if it has any additional details?

sure. that part happened before I got my hands on things, but as I’m aware an existing production server with on-prem IS was cloned (fully copied) to a new server instance (we are making a new cluster).

I’m working on firing up the IS now in order to make the necessary config changes in IS admin. I did several steps before attempting to fire it up like disabling schedulers, UM, and JMS connections, etc. I changed the remote.cnf file to point to new host name as well.

Then ran the startup.bat file which seemed to be successful. however cannot access the IS admin page from new server. So now debugging to see what the issue could be or if other configs needed changing

It will be interesting to see what the logs show?
Also, can you see that the IS server process running (in Task Manager)?
tasks manager

If you type “netstat -q” on the Windows command line do you see your IS ports as listening? On my laptop I’m running an IS listening on ports 5545, 5557 and 9997

Why about the server log, do you see the messages where it activates the ports ?

Checked task manager and this is what I see:

For the ports, would this be the port defined in remote.cnf (5555?)

For the logs, I’m looking in \SoftwareAG107\IntegrationServer\instances<instance>\logs but it doesn’t seem like server.log has been updated since the clone happened (back in April).

Is there another log somewhere on the IS that gets updated during startup?

Hi @daniel.evans ,
It is possible that the IS is not running , Can you check a couple of things

  1. In the IntegrationServer\instances\default\config server.cnf check for the watt property watt.server.port , this is the port the would be running on.
  2. If shutting down is an option, run shutdown.bat from profiles\IS_default\bin , then start IS using startup.bat -port .


1 Like

Hi Daniel,

can you check the logs under profiles/IS_default/logs?
These logs are updated during startup, even when the server.log has not yet been created or activated.


1 Like

Also try starting from the command line, that way if it fails you will see the likely error

cd \profiles\IS_Default\bin

The log file you want to look at is

did fresh startup from command line and checked status:


i deleted wrapper.log before running startup so now I have a fresh file. i’ve attached it but nothing jumped out immediately…

wrapper.log (74.7 KB)

also checking server.cnf i see the config is watt.server.port=5555

Looking at the logs, I see the following

INFO | jvm 1 | 2023/01/12 05:33:47 | Exception in thread “Thread-29” java.lang.NoClassDefFoundError: com/wm/app/b2b/server/AccessException
INFO | jvm 1 | 2023/01/12 05:33:47 | at com.softwareag.osgi.is.core.impl.ServiceFactory.create(ServiceFactory.java:8)
INFO | jvm 1 | 2023/01/12 05:33:47 | at com.softwareag.osgi.is.core.internal.Activator$ServiceRegistrationHelper.run(Activator.java:119)
INFO | jvm 1 | 2023/01/12 05:33:47 | at java.lang.Thread.run(Thread.java:748)
INFO | jvm 1 | 2023/01/12 05:33:47 | Caused by: java.lang.ClassNotFoundException: com.wm.app.b2b.server.AccessException cannot be found by com.softwareag.osgi.is.core_10.7.0.0001-0196
INFO | jvm 1 | 2023/01/12 05:33:47 | at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:460)
INFO | jvm 1 | 2023/01/12 05:33:47 | at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
INFO | jvm 1 | 2023/01/12 05:33:47 | at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:414)
INFO | jvm 1 | 2023/01/12 05:33:47 | at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:153)
INFO | jvm 1 | 2023/01/12 05:33:47 | at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
INFO | jvm 1 | 2023/01/12 05:33:47 | … 3 more

Above indicates that IS is not even getting started.

Can you please check wrapper.working.dir value in custom_wrapper.conf and ensure it is pointing to correct location? In addition, please also check config.ini located under profiles/IS_/configuration directory and check the value of watt.server.homeDir and ensure it points to the correct location.



thanks for your help.

checking customer_wrapper.conf I see: wrapper.working.dir=D:\SoftwareAG107\IntegrationServer\instances\JFWIS

checking the config.ini i see: watt.server.homeDir=D:\\SoftwareAG107\\IntegrationServer\\instances\\JFWIS

These seem correct to me.

Can you please attach sag-osgi.log, wrapper.conf & custom_wrapper.conf files here?


Requested files attached:

wrapper.conf (10.1 KB)
custom_wrapper.conf (2.2 KB)
sag-osgi.log (91.2 KB)

In the sag-osgi log, I was browsing and noticed these lines:

2023-01-12 07:23:16,754 ERROR [com.s.o.i.l.ISLauncher ] - Error creating Integration Server
java.io.FileNotFoundException: D:\SoftwareAG107\IntegrationServer\instances\JFWIS\config\server.cnf (Access is denied)

Can you please check if file D:\SoftwareAG107\IntegrationServer\instances\JFWIS\config\server.cnf exists and if there are any permission issues? We need to make sure that the error above doesn’t appear in the log file.


1 Like

yes, the server.cnf file exists:

Looking into any permission issues but upon initial look it seems to be the same as all the other files.

Hi Daniel,

please check the permissions for the user with which you try to start the IS and if the user belongs to a group which has the proper rigghts to access this file.


I’m not an expert on this but I tried to add my user to the security tab with read/write permissions for this file. I then tried to startup again, however the IS is failing to start up still. I don’t see the same error anymore.

also I checked the server.cnf file and it indeed had been updated. and also a little bit of the server.log file was generated (so we’re making progress).

sag-osgi.log (103.0 KB)
server.log (1.8 KB)

Looking in the server log it looks like there’s another permission issue:
Caused by: java.io.FileNotFoundException: config\auditing\AuditConfig.xml (Access is denied)

So I’ll try and resolve this globally instead of file by file. I’ll update when I sort out permissions. Thanks

1 Like

Update: the issue did indeed turn out to be a permission issue. I eventually went to the top-level SoftwareAG107 directory and gave my username full rights, which cascaded down to the rest of the file system. I then re-ran startup.bat, and now I’m able to access the IS Admin page.

Thanks to everything for your help. I’m sure I’ll be back on these message boards soon :slight_smile:

1 Like