Unable start Api Portal on Centos8 ( Runnable elastic_s is FAILED.)

Hi everyone,

I have started cloud agent and then trying to start portal. I opened the ACC with default command “./acc.sh -h localhost -u Clous -pwd g3h31m -p 18101”. When I try to start all components I got an error.

Unexpected error: Not all runnables of layer 1 reached STARTED.
Runnable elastic_s is FAILED.
Startall aborted.

I can’t start Api Portal. Can someone help me?

Hi,
99% of the time this happens, it because you haven’t allocated enough memory to your runtime. ELK is very greedy and requires approx 4gb just for itself. That’s why we often recommend to allocate at least 8gb of memory to a VM for hosting API Portal.

If you want to confirm the problem, check the ELK log file found in

/opt/softwareag/API_Portal/server/bin/work/work_elastic_s/logs/elasticsearch.log

regards,
John.
Product Manager
Integration & Microservice Runtime

Hi John,

Thanks for your reply. I changed vm memory and set vm.max_map_count = 262144 and it work. But now I have a different error. I get an error like this in CloudAgent.log

INFO | jvm 1 | 2021/03/30 16:35:47 | 2021-03-30 16:35:47,416|WARN |Thread-11331| com.aris.prov.agent.lifecycle.AbstractRunnableLifecycleManager - Found a non-qualified context property zookeeper.application.instance.context=/ but no bundle type (property zookeeper.bundle.type) was specified, ignored.

INFO | jvm 1 | 2021/03/30 16:37:04 | 2021-03-30 16:37:04,632|INFO |Runnable state monitoring thread loadbalancer_m| com.aris.prov.agent.plugin.base.RunnableStateMonitoringThread.loadbalancer_m - Ping level 1 ping failed.

And I can’t connect to localhost:18101 . When I look at the netstat it seems to be working.

EDIT

I noticed that loadbalancer_m keeps restarting after leaving the machine on for a long time.

The error written in the error.log(/opt/softwareag/API_Portal/server/bin/work/work_loadbalancer_m/httpd/logs/error.log) is;

Initializing shm:cif.255480 errno=13. Unable to start due to shared memory failure.

I don’t know how to solve this problem. Anyone have an idea?

Hi,
Looking at the log it looks like you still have an issue with memory i.e.

Initializing shm:cif.255480 errno=13. Unable to start due to shared memory failure.

You need to update a few other limits in your system. I have copy pasted the required config below

Check the setting for shared memory (kernel parameter shmmax) by executing the command 

$ sysctl -a | fgrep kernel.shmmax

If the value is less than 629145600, log on as root user and increase the value by executing 

$ sysctl -w kernel.shmmax=629145600 
or 
$ echo "kernel.shmmax=629145600" >> /etc/sysctl.conf

then activate the new value by executing 

$ sysctl -p

Check the settings for the system-wide maximum number of file descriptors (kernel parameter fs.file-max) by executing the command 

$ sysctl -a | fgrep fs.file-max. 

If the value is less than 200000, log on as the root user and increase the value by executing 

$ sysctl -w fs.file-max=200000 
or 
$ echo "fs.file-max=200000" >> /etc/sysctl.conf

then activate the new value by executing 

$ sysctl -p

Check the user, group, and process settings for the maximum number of open file descriptors by executing the command 

$ ulimit -Hn 
and 
$ ulimit -Sn 

where -Hn is the hard limit and -Sn is the soft limit. If the value is less than 200000, log on as a non-root user and increase the value by executing 

$ ulimit -n 200000

To permanently save this setting for the user, execute

$  echo "<user name> soft nofile 200000" >> /etc/security/limits.conf
$ echo "<user name> hard nofile 200000" >> /etc/security/limits.conf

Last wnter the host name of the machine on which you are installing products in the DNS of the network or in the file /etc/hosts.

hope this helps,
John.

1 Like

Hi @John_Carter4

This configuration help me a lot. Api portal now works properly.

Thanks.