two identically named services with different endpoints


I’ve got a question regarding the attachment of a wsdl, and accompanying xsd’s for two webservices with the same name, but different endpoints.

There’s one service which is used in an internal domain and one that’s used in an outside domain. The first service is for employees, the second one is for civilians. The first service is consumed by another application as the second one. A wsdl has been attached to the ‘internal service’. In this wsdl there’s an endpoint for the employees.
Then there’s the second service with the same name. No wsdl is attached here. When I do attach a wsdl to the second service, I get the message ‘The service is already present in the registry. Do you really want to update it?’. If I click ‘No’ then everything stays the same. I haven’t attached anything anywhere, so my problem has not been solved. If I click ‘Yes’ then the second service, where I tried to attach the second wsdl, is still empty, but the first service has been changed. The first service is for employees, but the ‘Access URI’s’ have been changed to the domain of the civilians.
So I did attach a wsdl, but to the wrong service! I tried to attach a wsdl to service 2, but it changed service 1. This surprised me a bit, since I would have expected every object to be identified with a unique uddi-id. But obviously it’s not that simple.

My question is this: how can I solve this problem and successfully register both services, with the same name, but another endpoint?

Best regards,

Michiel Jaeger
The Netherlands
Gemeente Den Haag

The best approach is to import the WSDL with localhost as endpoint for example. Then create two different endpoints for each of the virtual service.

The other solution is to change the WSDL in order to point to different endpoints. In this case you can import it directly to the CS.