Trying to set pagesize attribute in "browse"-tag

X-Application Version: 3.1.1
Tamino Version : 3.1.1.1
Platform : Win 2K
WebContainer : Tomcat 3.3
JDK Version : 1.3.1_02

If I try to set the pagesize attribute
of a “browse”-tag, I get this: (also when
trying to run the “simple” examples that)

Sorry if I ask something that has probably
been answered 20 times - but I couldn’t find
it.

Thanks a lot, Ralf Dierenbach

org.apache.jasper.compiler.CompileException: C:\diplomarbeit\ino\xapplication_311\examples\jsp\invoice\r_browse.jsp(25,0) Unable to find setter method for attribute: pagesize

[This message was edited by Christian Freytag on 26 Jul 2002 at 08:37.]

Hello,

I had the same error. In my case, I cleared the Tomcat compiler cache by deleting the content of the directory

%TOMCAT_HOME%\work

Bye,
Christian.

Christian,

thanks for the fast answer -
it works!

Ralf Dierenbach

Hello,
I recieve the same exception and clering the work directory doesnt solve my problem :frowning:
Can anybody advise me something else please ?
In my jsp I use the pagesize attribute for bdm:loop
I can not test my application :frowning:

I am using Windows 2000 Professional
Tamino 3.1.1
Tomcat 3.3
XApplication 3.1.2

Here is the exception

org.apache.jasper.compiler.CompileException: C:\Hasta\vHastaAlt.jsp(16,0) Unable to find setter method for attribute: pagesize
void org.apache.jasper.compiler.TagBeginGenerator.generateSetters(org.apache.jasper.compiler.ServletWriter, java.lang.String)
void org.apache.jasper.compiler.TagBeginGenerator.generateServiceMethodStatements(org.apache.jasper.compiler.ServletWriter)
void org.apache.jasper.compiler.TagBeginGenerator.generate(org.apache.jasper.compiler.ServletWriter, java.lang.Class)
void org.apache.jasper.compiler.JspParseEventListener$GeneratorWrapper.generate(org.apache.jasper.compiler.ServletWriter, java.lang.Class)
void org.apache.jasper.compiler.JspParseEventListener.generateAll(java.lang.Class)
void org.apache.jasper.compiler.JspParseEventListener.endPageProcessing()
boolean org.apache.jasper.compiler.Compiler.compile()
void org.apache.tomcat.facade.JasperLiaison.jsp2java(org.apache.jasper.compiler.JasperMangler, org.apache.jasper.JspCompilationContext)
int org.apache.tomcat.facade.JasperLiaison.processJspFile(org.apache.tomcat.core.Request, java.lang.String, org.apache.tomcat.facade.ServletHandler, java.util.Properties)
int org.apache.tomcat.facade.JspInterceptor.requestMap(org.apache.tomcat.core.Request)
int org.apache.tomcat.core.ContextManager.processRequest(org.apache.tomcat.core.Request)
void org.apache.tomcat.core.ContextManager.internalService(org.apache.tomcat.core.Request, org.apache.tomcat.core.Response)
void org.apache.tomcat.core.ContextManager.service(org.apache.tomcat.core.Request, org.apache.tomcat.core.Response)
void org.apache.tomcat.modules.server.Http10Interceptor.processConnection(org.apache.tomcat.util.net.TcpConnection, java.lang.Object[])
void org.apache.tomcat.util.net.TcpWorkerThread.runIt(java.lang.Object[])
void org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run()
void java.lang.Thread.run()

Hi All,
I changed my JDK version from 1.3.1 to 1.3 and now I dont recieve any exceptions :slight_smile: The exception goes off when I clear the work directory.
Thus I will be glad if someone can tell me whether I can solve this problem when I use JDK 1.3.1.

Server AYAYDIN

That’s surprising! … Could you re-check the
bevarior: does it work if you "step up to jdk 1.3.1 again?

Michael

Software AG Germany, Darmstadt

I stopped Tomcat, changed the JDK from 1.3.0 to 1.3.1 and started Tomcat again.
It worked and did not give any exception(Probably because the servlets were already in the work directory).
Then I stopped Tomcat, cleared the Work directory and started Tomcat again to see whether it would correctly compose my servlets :frowning:
It has again given exception and did not work.
That means I am right and it does not work with JDK 1.3.1

One more point,
The excact Tomcat version I am using is 3.3a
I dont know whether it changes anything or not.

Weired.

We searched the web for this particular error
message … maybe the problem is that
X-Application’s IteratingContextTag class
defines the methods
"int getPagesize()" and
“void setPagesize(String)”.
Tomcat can get confused if a getter method does
not return the same type as the setter method’s
argument.

As a work-around, you could try to rename
the “int getPagesize()” method to
“getIntPagesize()” and fix the references in the
BrowseTag class.

Unfortunatly I cannot reproduce the problem here,
so I can’t promise anything …


Michael

Software AG Germany, Darmstadt

Hello Michael,
I have made the changes you’ve told on IteratingContextTag and BrowseTag classes.
Thanks God it seems working right now :slight_smile:
May I want you to make these changes in the new version too please?
By the way my problem with pagesize was with the Loop tag.
Many Thanks
Server

I want to use this updated tag in my application. I find that I cannot display all records from a direct command. Please let me have the tag.

the problem is solved for X-Application 3.1.3