Trigger WM 61

hi ,
I am using Borker for my publish doc and i got Trigger who sub to those publish documents,Its working for me ,
but suddenly my Trigger dosent work, i need to create New Trigger
or i need to start The Broker Server from Admin .
is this unusual problem ?
I tested with 2 test progrms for that.It happen for both of the Programms.i will appreciate If any one has been with similar issue
and how did you overcome this issue .

Thanks,

Kitt,
Maybe what you can do is mention the Service you are calling in the Trigger again by removing that service first,saving it and then again pointing to that service.It helps sometimes.Another option is to clear the documents from the Trigger queue(if it is in Development or Test…please dont do it in Production if the data is critical).Sometimes the documents get stuck in queue and the Trigger doesnt process them.If you clear the queue it works fine.(atleast for me it did…)…Another option is as you mentioned delete the Trigger and recreate it…Hope this helps…

Thanks,
Puneet Verma

Hi,
I have a issue like this.In my IS-Broker-IS solution,I publish some documents to Broker from one IS,and another IS subscribes them.The issue is,when I publish too many,in the beginning all work fine,but after a while the IS subscribing documents will throw out a exception “[LGU.0002.0001E] Error getting Broker log length:Unable to send to Broker.Error ‘java.net.SocketException:Socket closed’ was reported by the send call” ceaselessly and the connection is lost.The trigger is configed “Exactly-once” mode,and the platform is webMethods 6.1.

Oh,Excuse me,I forgot to say “Thanks”.
Thanks for your help.

Thanks Puneet,
yes i am able to Subscribe to that documents which i publish
when i re-created the trigger It worked fine
but i was wondering what happen if it get stuck in the Production ,
we don’t have control to create the trigger each time .
We need to have some kind of FIX for this Problem from webmethods .

one question how to is to clear the documents from the Trigger queue?
ok thanks ,

Kitt,
There might be some FIX for it.I am not sure.Maybe somebody here in this forum can tell if there is a FIX available from webMethods for this problem.Or you can raise this issue with webMethods itself.
To clear documents from Trigger queue follow the following steps:

  1. Go to Broker Admin page.(http://localhost:5555/WmBrokerAdmin)
  2. Click on the Broker Servers on the Broker Admin page.
  3. Go to the Brokers in that Broker Server.You can see the Brokers tab at the top if you are using 6.1 version.
  4. Click on the Broker.(can be any name you kept while creating brokers)
  5. You will see the Document Types, Client Groups and Clients mentioned under Broker Information.
  6. Click on the Clients.There you will see a client with your Trigger Name in the Client ID.
  7. For that Client ID you will see a column called ‘Documents in Queue’.You can click on the ‘Documents in Queue’.
  8. On this screen you can say Clear Client Queue.It will ask for confirmation.

But use this in Development or Test environment only.Hope this helps.

Thanks,
Puneet Verma

Kitt,

When the problem occurs, can you check to see the number of sessions you have that are connected. Go to the BrokerAdmin page and drill down to the clients on the broker. Find the trigger that isn’t working and check the number of sessions. You can click on sessions and check to see if you have more than 1. We had this problem and webMethods TS got us to install BrokerCoreFix-1. Prior to install the fix, we would get rid of the “old” session and this would then allow the triggers to continue processing. webMethods TS explained that our triggers were setup to process sequentially and the first session was in a “hung” or “disconnected” state. By deleting that session, it allowed the next one to pick up the document and process it.

Please note that we did install BrokerCoreFix-1 and the fix corrected the problem of multiple sessions, however, we now have a different flavor of the problem. My triggers go to a disconnected state. I’m currently working with webMethods TS to resolve this issue.

Kenny:

We had the error that you had and that was thrown by the WmLogUtil package. WebMethods TS believes there was a fix for this in 6.0.1 but not in 6.1. The messages are just that… messages. In our case everything was up and working. (I published documents and the broker was receiving them.) TS had us stop the log util process by going to the Package Mgmt screen and going to the WmLogUtil home. From there we clicked on the “stop” link and this eliminated the messages. We are still investigating with webMethods TS why this starting happening …

Thanks Brigitta & Puneet
To share your experiences ,I will be greatly interested to know the out come of the issue “triggers go to a disconnected state”

we also trying to contact the Broker issue with Webmethods guys.
As we are able to publish to Broker and sometime I can’t subscribe to those documents.and each time I create new Trigger but its not a good practice, but it worked for me …

Regards.

Kitt,

Please let this forum know what ever resolution given by WM support folks any fixes or like that.so that it will be helpful for future threads,

Thanks,

Hi,Brigitta
Somebody tell me the reason for the exception is more than one IS WmLogUtil being enable connected the same Broker.He suggest me to disable the other WmLogUtil of other IS but remain just one of one IS.I done like that,but the exception still occured.
Maybe webMethods have issueed some fixes for this…
Thanks.
Kenny

Hello to all,

I would also be really interested to have an answer to these subscription problems.
We have actually experienced quite some of these problems on 6.0.1 (disconnected clients corresponding to triggers and hanging clients with more than 1 session), but we have not really found any solution so far.
The only thing I could say is that it seems better with latter version of the broker core (SP2 fix 3 and later).
Concerning WmLogUtil with two IS (we actually never tested it really, except in an OS cluster), it basically can not work according to wM TS. Indeed, the queue of the WmLogUtil (which can not be seen anywhere) does have the name and port of the client machine (the one running WmLogUtil) hardcoded.

Best regards,

Ch’tig

Hi all,

We have the same problem with documents stuck in the trigger queue and multiple sessions. Is there any solution or fix that could solve the problem? It is a big problem to us as we’re moving towards production.
Thanks for any advice!

Best regards,
Samuel

Hi All,

I’am working on webMethods6.1 and my OS is Solarsis, As my dirve in the solarsis was full and the server shows outofMemory and my developer got hanged-up, so I shutdown the IS and have moved all the webMethods Logs into some other drive to free the space and restarted the IS. From then iam can create a trigger but can’t name that trigger or modify the trigger or delete the trigger, I have shutdown and also restart the server but there i get the same error. what might be the problem.

error is The following elements were not deleted: osp/Osp.triggers:generateResp

Thanks in advance
RKK