Trigger using A Thread all the time

Hi All -
I am using retry until success to put messages in MQ, when i send the request to webmethods it is processing as it should (Main srv publishes document, this triggered the subscriber, if there is a failure to put message it retry’s).
I went into MWS, Administration, Messaging, Broker Servers, Clients - ‘Queued Docs’ will be 1 but ‘Last Retrieve’ will be ‘never’ and In IS admin page - Settings > Messaging > webMethods Messaging Trigger Management > under the Document Processing - Current Thread Count is one all the time

i don’t want the trigger using “one thread” all the time.

Trigger properties :
Capacity: 10
Refill level: 4
Acknowledgement queue size:1
Retry until: Successful
Retry interval: 6 minutes
On retry failure Throw exception

Check Trigger Processing Mode in trigger properties.

HI Mahesh, thank for getting back on this,

Processing mode: Serial
Max execution threads: 1

I suspended both Document Retrieval and Document Processing still the Current Thread Count was ‘1’

Can you change this to Concurrent option and try as below?

Processing mode: Concurrent
Max execution threads: 10

HTH,
RMG

Hi Madhukar,

you might want to take a look at this article in the community wiki:

http://techcommunity.softwareag.com/web/guest/pwiki/-/wiki/Main/Setting+Correct+Trigger+Parameters+

This contains a lot of helpful information, i.e. which trigger processing mode to use under which conditions.

If the order of the messages is important you must make sure that there is only one thread active.
When running with more threads it might happen that the second message gets processed before the first one is completely processed.
I.e. if you have a Create and an Update for the same business object and the Update starts its processing before the Create is completed the might fail as the business object is not yet in a valid state.

Regards,
Holger

Hey Madhu,

Hope you got your answers by now. Let us know if you still have any issues or questions.