Trigger JMS : lost message

Hi,

we get an error with JMS trigger when there is documents in the JMS queue and the IS is restarting.

We tried using “pub.flow:throwExceptionForRetry” but it was not successful : The service “pub.flow:throwExceptionForRetry” is executed (an entry appears in the service usage menu) but the flow service is not re-executed.

The trigger’s configuration for this test is :

  • No Transaction
  • Client acknowledge

Based on the webMethods JMS’s client developer guide, we also tried using a transacted JMS trigger (Local transaction).

However, this test has also failed with this error in the server log : “JMS Trigger <trigger’s name> failed preprocessing: java.lang.Exception: Unable to retrieve the ART transaction manager instance. The WmART package may not have loaded correctly.” (the package wmART is loaded well).

Futhermore, the flow service is also never called (no entry in the service usage menu).

This error occurs during the starting process of the IS after the JMS connection alias and the package which contains the JMS trigger are activated.

And finally when the IS is completely started, the documents are still beeing held by the JMS trigger (not in the JMS queue anymore) and the only way to get them back is to manualy disable and enable the JMS trigger. So documents are not lost but it needs a manual intervention to process the documents retrieved during the starting process of the IS.

How ask to the server to not consume JMS message until it finishes to start ?

Thanks

I answer myself, if you’re using webmethods v7.1.2 you must install the core fix v28 or sup to resolve this problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.