Trigger and Broker Document

I have a process model which receives Broker Request document, processes the information by calling a web-service using a flow-service whose fields are mapped to broker Response. This broker response is returned to SOAP IDD through process model step that calls pub.publish.reply. When I execute this process for the first time, it throws the error:
“2008-09-09 13:39:26 CDT [ISS.0098.0024C] No Trigger available for incoming Document XYZ.docs:Response. Rejecting Document”
immediately after the flow-service calling the web-service executes normally(no failure). Next time I execute the process model, I get the similiar error but after the process model ends properly and is a success.

I tried deleting and recreating execution and transition triggers that are created by process model from MWS. I also tried restarting the server and infact also re-created the process model. But the problem still exists.

Thanks

Hi Sayli,

Did not properly about your steps,
assuming its like this :

  1. Receive
  2. flow -> webservice
  3. reply

For any reply, request is mandatory. Where are you publishing request document?

Regards,
Sumit