TN with Oracle 8i

Hi Julien,
We recently had the same issue. We found the following URL worked
Database URL= jdbc:oracle://hostname:port:SID=ID

Our URL is jdbc:oracle://hub:1521:SID=TN.

Hope this helps.

Jim Palmer

Also, the documentation for this is nonexistent. We got our solution after discussing the isuue with WM support.

Jim

Hi Jim,

thanks for your reply. I tried the URL you advised, but with no success. I still get an ‘Invalid URL’ when testing the functional alias. What I did is remove the pool alias I defined for the driver provided with Oracle, and also removed the classes12.zip I previously put in the lib/jars folder. I then set up a pool alias using the pre-defined DataDirect driver alias. What’s your configuration ? Are you using Oracle 8i with WebMethods IS 6.01 ?

Julien

I finally found a valid URL :
jdbc:oracle://host:1521;SID=ORCL
(mind the semi-column)

I know this is a pretty old thread… but Im trying my luck any way. I am getting the notorious “Invalid URL” (when using the url: jdbc:oracle://hostname:port;sid=sidName) error when testing the TN JDBC Pool. I am using webM 6.1 with Oracle 8.1.7. I am using the pre-configured Driver Alias webMethods DataDirect Connect JDBC OEM driver. However, when I use the URL jdbc:oracle:thin:@hostname:port:sidName, it works fine. But then when I start the TN Console, I get an error saying “unable to fetch model version information from your database”.

I read in a thread on the advantage site that the later url creates problem while fetching info from TN, thus I want to try the first url to see if it resolves the error I am getting in starting the TN Console. Any help is appreciated. Thanks,
Rohit