throwExceptionForRetry not working for queue

Hi all,

I am quite new to webmethods and am trying to implement a trigger service with a retry. I am using a mock service to return a SOAP Fault to the trigger service which causes the flag for throwExceptionForRetry to be set as true. I can see by using a debug log that the service is inf act reaching the pub.flow:throwExceptionForRetry service but then nothing happens.

Previously i had a topic instead of a queue and the retry worked correctly then, since changing to a queue it no longer seems to work and i can’t see why

Any help would be greatly appreciated

Thanks

Chris

Hello Chris,

Happy New Year!

Just trying to get clarification on your issue. When you say Queue are you using Broker pub/sub here or UM topics part of your messaging configuration?

HTH,
RMG

Hi, and Happy New Year to you too!

I am using pub.jms.send to send the jms message to a UM Queue which is then picked up by the trigger. Not sure if this is relevant or not, but even when the service is working correctly i cannot see any hits on the queue when i snoop. I can however see events being pushed onto it, but only once, no retries

Now, even changing back to the topic which used to previously work, does not work

Chris

Solved it… I had the finally sequence set to exit on done instead of failure…

Glad to hear that!

It sounds to be a Try/Catch sequence labeling issue?

HTH,
RMG