The prefix "soapenc" for attribute "soapenc:arrayType" is no

I’m calling another Web Service and gets the follwing error:

The prefix “soapenc” for attribute “soapenc:arrayType” is not bound. Attached it the trace file. The sequence looks like this

<?xml version="1.0" encoding="UTF-8"?>

The xml document used to set the payload, looks like this:

<m:searchByRegion xmlns:m=“capeconnect:GlobalWeather:StationInfo”>


Any idea why I’m getting this error and what I could do to fix it?

Theo (212 KB)


This could be a bug. We’re looking at it now.


Hi Theo,

Here’s the problem: We dumped out the raw SOAP message returned from the Web Service, and the SOAP-ENC namespace prefix is declared in the outer SOAP envelope element, but we only extract the child of the SOAP body element and put that into the return Mediator message. Unfortunately, that XML fragment does not include another SOAP-ENC namespace declaration, so we end up with an invalid XML fragment, since that prefix is used in the fragment.

The developer has fixed it and we will know next week if we can deliver it in the 7311 or 7312 patch.



Thanks Jason,

the fix worked great.