Task Customized Comment portlet issue

Hi all,

In wM 8 Sp2, I am working on showing task comments in taskview portlet.
to try this I created a task with customizable comments portlet, when I try to test custom comments portlet by queuing task from start task portlet,I get this message “No comments container specified”. When I checked what is passed for the import portlet control in task overview portlet (for inbuilt comments portlet), commentControlID preference is set to taskid. I tried passing the same but I got Nullpointer exception.
Could someone help with this. I want know why the customized comment portlet is showing “No comments container specified” and IS there a better way to show comments in taskview portlet itself.


I haven’t tried replacing the comments portlet, but if you want access to the comments you can use the following code:

TaskCommentsListProvider tcl = new TaskCommentsListProvider(); 
ICommentEntry[] comments = tcl.getCommentsList();

Hope this helps.


When we gen it in Designer, the provider initialization looks like this:
public CommentsListProvider getCommentsList() throws Exception {
if (commentsList == null) {
Boolean forTask = getResultsValidationComments().getForTask();
commentsList = (CommentsListProvider)resolveExpression(
forTask != null && forTask.booleanValue() ? “#{taskCommentsList}” : “#{commentsList}”);

we were wondering who/where initializing “#{taskCommentsList}” variable? Thx.

Make sure you also set the forTask preference to true.

Hope this helps,