Subscriber Service not invoked

Hi All,

I face a strange problem.

I have created a trigger which subscribes two documents and have given filter condition for both the documents. The activation id is also mapped while the two documents are getting published. This trigger is working fine in one environment and the subscriber service is also getting invoked.

But the same trigger is not working in the other environment (ie) the subscriber service is not getting invoked. I can also see that both the documents are getting published in this environment. Eventhough the subscription service is not getting invoked.

The code present in both the environments are same.

Could anyone help me on this?

-Ambrish -

Hi Ambrish, surely you did it but I have to do this question: Did you “Sync Document Type >> Push to Broker” with the right button menu?



Yup, I did that . :slight_smile:

- Ambrish -

Seems to be a broker problem or a data filtered in the second environment but I assume you are testing with the same data to try to find the error. I remember I had the same problen +o- 3 years ago, is a strange problem but the only way I fixed was set the document to not publishable and then re-set to publishable and push to boker again. I don´t know wath happend behind but that action was the solution. Sorry for can’t help.


Thanks for the suggestion.

I tried first disabling and enabling the trigger which worked. :slight_smile:

- Ambrish -

great! I’m glad