Strange behavoiur of JDBC database adapter services

I am having peculiar problem with the database adapter

I have created a adapter connection to oracle database and created the adapter services

I am trying to insert the data into status table which includes date field

When i run the adapter directly i was able to insert the data,but when i run the same through flow service ,service hangs at adapter service stage and not throwing any error also

Strangely when i run the select adapter service i am getting different data records than existing in database

If some one have alrady faced this or if you have some soultions for the same ,will be very thankful

I am spining around this.

Thanks in advance

Try to reload the Adapter service then refresh IS SERVER .

Done lot of times still no luck:((


Try increasing the log

  1. trace for JDBC Adapter
  2. Under IS
    0004 JDBC Connection
    0114 , 0115, 0116, 0117, 0118, 0121, 0126

You may get more info

Can you describe the data types you are passing to the adapter service when run directly and from the FLOW service? If it is a string, what is the format being passed?

What level of fix are you at? also does the table have any indexes defined?

Are you still having this issue? If so, please provide what kind of adapter you’re using (local vs no transaction) and what the setting are for the adapter. That is a good start…

Hello All,
I was able to solve the issue as the auto commit was not happening in the SQL plus (database)



I am facing some similar issue.
I have a JDBC Insert adapter which runs correctly when I run it directly or thru any service, without any errors but I dont see any data in database.
I cant see anything in Error or Server Log.

Not sure what the issue is . Can someone plz help on this.

try puting the adapter service in a try catch block and use proper start ,commit and rollback transaction,you can see if any error is coming while executing the service.


Hi wMprof

If data is not mapped properly to the column in insert adapter service the record is not inserted check what data u r passing.