StoredProcedureWithSignature, Cursor problems

Dear Community,

we have ran into a situation here with the Oracle Cursor type as a return value in a stored procedure.

Let’s start with the error message:
[ADA.1.316] Cannot execute the SQL statement “{call MYPACKAGE.MYPROCEDURE( ?, ?, ?)}”."
[I]SIZE=2 Cursor is closed."[/i]
[/SIZE]Cursor is closed.

The signature of the procedure is: ( IN number, OUT cursorType, OUT cursorType )

We have consulted with the person who created the stored procedure, double checked the code, and apparently the returning cursors are not closed in any place, and the opening parts of the code are not in a branch, so the cursors are open when we receive them in the signed procedure (even if there is no result in the opening select).

I have set up the result set according to the signature as well, and a couple of weeks ago it worked perfectly fine, until some changes were made in the database.

We are working on an IS with version number 8.2.2, JDBC Adapter version 6.5.

We are really stuck with this problem, and the deadline is getting closer. Any help, and feedback would be appreciated.

Best regards,
Ákos

Hello Akos, please review the message thread below previously posted with similar question. Below is the link to the thread. I hope that it is helpful.
http://www.wmusers.com/forum/showthread.php?22942

Hi dcova!

Thank you for your input, we asked the database developer to close the cursors in the procedure, however this did not solve our problem, the response is still the same.

Regards,
Ákos