Stored procedure call and large CLOB as input

Has anyone been able to do a stored procedure call (oracle 9) using JDBC/OCI, with a large CLOB as the input parameter passed in?

Right now, it works only with clobs up to 32mb where we get error below. wM support thinks is a limitation with Oracle. [ART.117.4002] Adapter Runtime
(Adapter Service): Unable to invoke adapter service ocitest:abi_insert.
[ADA.1.316] Cannot execute the SQL statement “{call SCOTT.LOAD_XML (?,
?, ?) }”. "
(65000/6550) ORA-06550: line 1, column 7:
PLS-00306: wrong number or types of arguments in call to ‘LOAD_XML’

Unfortunately, we can’t do a straight insert service (which does work)



Hi John-

I’ve seen a similar size limitation with BLOBs being submitted into Oracle with the Oracle ‘thin’ database driver. However, our sitation was different to yours - the limit we saw was much below 32 MB and the problem occured with inserts too.

Installing a different Oracle driver (driverType=oci) solved that issue.

Unfortunately, we are using OCI, and we still get this problem.