Starting wM IS as a windows service fails [1]

Hi,

I installed wM Integration Server 6.0.1 SP2 at one of our windows servers with “Start as Service” enabled. Unfortunately it won’t start up as a service. The event log shows the following error:
"The webMethods Integration Server 6.0 service terminated with service-specific error 2147500037. "

Starting it as a normal windows program works without problems.
One thing which differs in our env: We are using port 5556 instead of 5555 (because of HP Openview)…

Thanks,
Thomas

In the Event Viewer Application Log, we get this error:
[webMethods B2B Exception] [wmIS] Failed to create JVM during initialization because <Java classpath can’t be empty>

The JVM which we use is standard which comes with wM. I found out that there are two JVMs installed: D:\webMethods\jvm, D:\webMethods\IntegrationServer\jvm. The latter is used in the server.bat script.

R.,
Thomas

I have installed the IS on many PCs and there are a few that have this same problem. I have an SR open with support on this problem. I’m even using port 5555. If you find a resolution, I’d like to know.

Thanks,
Steve

Have you guys found out anything on this? I am seeing the exact same issue here.
We need to have the IS running as a service since the Admin of the box is not always logged in and I dont authority to run the IS as a program.
Thanks

Hello all,
Working with support, here is a fix that has worked for us, it might work for you too. We were having problems after changing the JDK, so if that is not your problem you may eliminate those steps. (Prudence implies any backups first).

Install/Reinstall IS 6 as an NT service

  1. Uninstall wMIS service with the <wM6\IS>\support\win32\installsvc.bat file as “installsvc unreg”.
  2. Uninstall old JDK.
  3. Install new JDK.
  4. Update <wM6\IS>\Server.bat file to locate the correct JDK path.
  5. Remove any LOCKFILES <wM6\IS>\LOCKFILE
  6. IMPORTANT STEP Remove any records (after backup, if necessary) from <wM6\IS>\data, <wM6/IS6>\datastore and <wM6\IS>\DocuementStore.
  7. Run <wM6\IS>\support\win32\installsvc

-Howard

All…

We were experiencing the same problem. The lockfile suggestion corrected our situation.

Here’s a note from my NT Server support person:

Well, there was a LOCKFILE left in the integration server directory. Apparently a LOCKFILE is created when the Integration server is running and deleted when it is stopped. However, sometimes if the server isn’t shutdown properly, the LOCKFILE remains behind which prevents you from starting the integration server. So, I went in and deleted that file and was then able to start the integration server service. But, then I was unable to start the “WebMethods Broker Server 6.0, port 6849” service. To resolve that, support had me rename broker.qs to broker.qs.old in the S:\Sysapps\webMethods6\Broker\data\awbrokers60\default directory. And, this corrected that issue.

Thanks for the help…

  • Scott

Hi All,

we had success in installing the wM service under a different (windows) service name (default is “wmIS”, just use another one). It seems that some of the settings in the registry are not deleted when uninstalling a service (see some other thread about this problem, too).

Thanks for all feedback,
Thomas

I know I’m a bit late with the answer but this might be helpful for anyone who strikes this problem in the future:

If you’re running IS 6.0.1 with JVM 1.4.x, there’s a file you need to delete.

Go to the \jre\lib folder under the JVM 1.4.x installation and remove the file jce.jar (copy it somewhere outside the JVM folder structure before deleting it of course!).

This got rid of this problem for us.

Peter Martin
www.hubco.net.au