Sso configuration using Azure AD in Cumulocity

c8y version: 1018.503.1

I am trying to configure Sso configuration in Cumulocity but I am getting the following error when I tries to log in using sso.

Sorry, but we’re having trouble signing you in.

AADSTS700016: Application with identifier 'axxxxxx-4xxx-4xxxx-axxxx-1xxxxxxxxx' was not found in the directory 'myDirectory'. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You may have sent your authentication request to the wrong tenant.

but I have configure the correct application id in Cumulocity tenant after checking it in azure tenant ,still getting this error

are there any other configuration to be done on azure tenant or Cumulocity tenant for fixing this issue, I am using free trial version of azure

Hello Rushikesh,
this message is not reported so far.
Please let me know the URL for the affected tenant. If it is hosted by us, then I can check it.
Do you mean with “application” a setting in {url}/apps/administration/index.html#/auth-configuration/single_sign-on in box “Access mapping” under " Default applications"?
Does it work when you set only “administration” here?
Regards, Christian