SQL Gateway z/os port assignment

Mainframe z/os SQL Gateway V12.

V11 was installed about 4-5 years ago and tested.
Installed V12 last week. 1st week on site at customer.

Received: ACCEPT: Acceptor could not be initialized on Port 6500.

Tried V11 version that worked before, it received same message.

I know that have upgraded z/os over the years do not know if there are any TCP/IP enhancements or not.

TCP/IP netstat inquires show that the port is not being used.
Tried different series of ports with same message.

Cannot find this message in the CONNX documentation.


Mike Waldron


Please set DEBUG=1 in the CNXPARAMS and try to start the listener again. If you are certain that the port is not being used at all, then it could be a security restriction issue.




268115142: Variable = CNXLISTENER :Value = CNXRUNA
268115142: Checking if Listener is running on port’6502’…
268115142: szInitInfo2 = 6502; nClientPort = (6502)
268115142: Connecting to port (6502) (
268115142: >> NET Error NetConnect: Unable to create socket.
268115142: >> errno=(63)(Resources temporarily unavailable)

Hi Mike,

I suspect that the local loopback IP address of may not be configured.

The error you are getting only applies to using CNXSTART console command.

Can you instead just submit the batch job directly by submitting the JCL member CNXADAJ please?



mmm that’s what i did.

While on the mainframe are you able to ping the address ?



will check

yes I can

Problem fixed with the addition of a TCPIP data dd

thanks for the responses

Hi Mike,

I’m glad your up and running - it is sometimes hard to diagnose issues over forums without jumping in and looking at the JCL via a support session.