[SOLVED] openCAF Shell Javascript method not working

Hi All,
I am having this problem with OpenCAF Shell, where I included Search Bar and Search Result Portlets in xhtml file using <mws_ui:resource /> and when I try to press search nothing happens, and the page does not even reload.

I also get this error in the console


>TypeError: element.getAttribute is not a function
            Element.getAttribute()           general.js:6668
            CAF.model()                        general.js:9888
             onclick()                              InboxTesting:1

Please specify what version and fix level of MWS you are using.

Also, it would be best if you can create a simple test project that demonstrates the problem and attach it here for further evaluation.

Dear Eric,
Thanks for the quick reply, and sorry for my delayed answer. I actually solved the issue. The problem was in the JQuery File that I tried to include which caused the general.js file to go crazy. When I removed the include the problem got solved.

To use JQuery you need to use JQuery no Confilict
https://api.jquery.com/jquery.noconflict/

1 Like

Yes, that is correct.

This is demonstrated in the OpenCAF Showcase sample at http://techcommunity.softwareag.com/ecosystem/communities/public/webmethods/products/bpm_suite/codesamples/8ff47897-062c-11e6-b2c6-cd8d7ef22065/?title=OpenCAF+Component+Showcase+9.10

1 Like